1.12.2 Option in MCreator?

Started by jadenquinn8 on Mon, 02/01/2021 - 10:57

Topic category: Feature requests and ideas for MCreator

Last seen on 07:56, 5. Apr 2021
Joined Oct 2015
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
1.12.2 Option in MCreator?
Mon, 02/01/2021 - 10:57

I've been making mods for quite a few (4) years now, and the one thing I hated about making mods on my own is that I have to pick a version that people play, because if I get stuck on 1.9 for example instead of 1.7.10, that becomes an issue very quickly.

Since 2017, clearly the most popular version for ANY set of mods is 1.12.2. It's just essential all over the place, and everyone that plays with mods is more likely on either 1.7.10 still, or have updated to 1.12.2 due to most of the big names updating to 1.12+ nowadays in late 2020 to early 2021.

I recognize this and would love to create mods for this version (1.12.2), but I am unable to, due to the fact that MCreator versions that would produce a 1.12.2 compatible version (since I don't code and really can't learn how to) just doesn't run at all. It gets stuck on "Loading Plugins". Some kind of "Internal Blockly Loader" error.

 

Due to this, I have come here to ask for a new MCreator plugin (because I've already tried the one that comes in the plugins folder of that old version of MCreator I mentioned, it literally doesn't do anything on newer versions of MCreator at all), which would let people make 1.12.2 mods with MCreator once again, since it's obviously still the go-to version for mods nowadays, and just until most of the big name mods have updated to 1.15+, I think this is a great idea for the time being.

 

Thank you for taking this into consideration,

-jaden-

Last seen on 18:34, 28. Feb 2021
Joined Feb 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Uhh To make a 1.12.2 mod you…
Fri, 02/19/2021 - 14:45

Uhh

To make a 1.12.2 mod you need to download a plugin in .zip form.

Then go to preferences and load a new plugin. After that select the .zip file.

And go to workspace settings then change the version to 1.12.2.

It can break some codes but you shouldn't worry about it. (I guess)

 

 

Note: Generator can be broken cuz it just broke my mcreator but you should use it and don't care about me