Arduino - Procedure of multiple LEDs doesn't work

Started by CrazyManCZ5 on Wed, 02/17/2021 - 18:57

Topic category: Bugs and solutions

Last seen on 12:20, 1. Mar 2021
Joined Feb 2021
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Arduino - Procedure of multiple LEDs doesn't work
Fri, 02/19/2021 - 15:10 (edited)

Hello,

currently I am trying to make procedure, that lights up my LEDs. The problem is when I join the world, only 1 LED lights up. Others are still off.

I am sending here, how the procedures look like.

Defining LEDs

Turning LEDs on

Edited by CrazyManCZ5 on Fri, 02/19/2021 - 15:10
What happens if you try to…
Sat, 02/20/2021 - 20:04

What happens if you try to change the order of blocks that turn on LEDs?

Last seen on 12:20, 1. Mar 2021
Joined Feb 2021
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Do you mean change the order…
Sun, 02/21/2021 - 10:01

Do you mean change the order of pins ? If I start with different pin, everytime, it lights up only the first one.

Different pin order

Last seen on 16:26, 28. Feb 2021
Joined Nov 2018
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Try making the pin in…
Sun, 02/21/2021 - 18:03

Try making the pin in numerical order. 10, 11, 12, 13

Last seen on 12:20, 1. Mar 2021
Joined Feb 2021
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Still the same. Only lights…
Sun, 02/21/2021 - 21:42

Still the same. Only lights up the first one (10).

Last seen on 12:20, 1. Mar 2021
Joined Feb 2021
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I've been searching through…
Tue, 02/23/2021 - 10:33

I've been searching through forum and I found this case kind of similar:

https://mcreator.net/tracker/issue/60264

Although, the workaround doesn't work for me much. When i do this workaround it fully lightsup the first LED (green) and the others are not bright as much as the first (see below).

LEDS

Last seen on 12:20, 1. Mar 2021
Joined Feb 2021
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Hello, I am being really…
Fri, 02/26/2021 - 18:42

Hello, I am being really desperate and I am still thinking about it. I don't know what to do about it. I am begging for your help please. Is someone willing to help me please ? :(