Mob cant hit monsters

Started by Caviar_Standaard on Sun, 02/28/2021 - 17:34

Topic category: Help with MCreator software

Last seen on 21:20, 14. Mar 2021
Joined Jul 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Mob cant hit monsters
Sun, 02/28/2021 - 17:34

I made a mob that attacks monsters like zombies but instead it just pushes them, this is the 1.12 plugin so that may be the cause but i doubt this matters.

Last seen on 17:29, 7. Apr 2021
Joined Feb 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Hello, indeed, the problem…
Sun, 02/28/2021 - 20:50

Hello,
indeed, the problem could possibly come from the fact that you did not update your MCreator client.
But it can also come from the fact that in the box "Attack Strength", in the category "Behavior" is too low. Maybe because the zombie armor is too high for your entity's attack, or you left the default of 0.

If not, it certainly comes from a design flaw in either the "Triggers" or "AI and goals" category or even perhaps the creation of the entity.

Otherwise, I do not see.
Looking forward to help you.

Last seen on 21:20, 14. Mar 2021
Joined Jul 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I did some of your…
Mon, 03/01/2021 - 02:20

I did some of your suggestions and they for some reason didnt work.