The Procedure is "Corrupted" ? (nothing shows up in it)

Started by LEPRODOR on Tue, 03/16/2021 - 21:30

Topic category: Troubleshooting, bugs, and solutions

Last seen on 14:27, 4. May 2021
Joined Mar 2019
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
The Procedure is "Corrupted" ? (nothing shows up in it)
Wed, 03/17/2021 - 21:48 (edited)

Ahoy ! After a long time with no issue, it had to come back someday :p . So, i "build" a very long procedure. The problem is, that when i try to edit/open it, nothing shows up in the procedure editor. There isn't even the slightest block to be seen.

I am using the latest version of 2020.5.

I am thinking , as i said it was big earlier, that the problem might be in fact its size. And yes, i noticed ONE forum with the same problem as mine i believe. But they said they fixed it with a restart, which on my part, didn't pay out no matter how many times I tried. So let me know if you guys have an idea to solve this really frustrating problem.
(I forgot to put Global Trigger to "On Player Tick" and i can't go change it now..)

Edited by LEPRODOR on Wed, 03/17/2021 - 21:48
Sometimes there is no other…
Thu, 03/18/2021 - 08:58

Sometimes there is no other way than re-making it and making sure it is not too big.

Last seen on 14:27, 4. May 2021
Joined Mar 2019
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Aouch. Yeah that's what i…
Thu, 03/18/2021 - 13:57

Aouch. Yeah that's what i thought..
But i do not need to edit it back if it's done correctly. Just the fact i forgot the "On Player Tick" Global Trigger makes it bad. It took a long time to do and i have to remake it 17 times. (normally 16 but since the 1st one is glitched, yeah)

But anyway, if you happen to find a solution to this, i'll be glad to hear it for the future.
For now i'll do as you say, remake it.

Thanks a lot, sincerely.

Last seen on 12:56, 6. May 2021
Joined Jul 2018
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I understand your pain…
Thu, 03/18/2021 - 14:44

I understand your pain... Happenes to me a lot of times. The first advice is to export the procedure when it's done so when it got corrupted you can import it again and make some optimalization or divide it into several procedures. The second advice is to collapse some of the procedure blocks to make it smaller. Sometimes it helps. Working on the procedure may then be little laggy but at least you can work on it. And of course allocating more RAM can help.

Last seen on 14:27, 4. May 2021
Joined Mar 2019
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Ah! Of course! Thanks to you…
Thu, 03/18/2021 - 15:01

Ah! Of course! Thanks to you, i didn’t think of those. I’ll try them out to see what happens with it!

it’s true i never think of collapsing blocks. It looks like a good idea.