Gui problems

Started by viatrophy997 on Wed, 03/24/2021 - 12:20

Topic category: Help with modding (Java Edition)

Last seen on 16:07, 12. May 2021
Joined Mar 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Gui problems
Wed, 03/24/2021 - 12:20

Hello, so I made a Travel Bag as armor (body) connected it to a key (g) so when pressed it opens the gui for player if he has the item in his inventory, but i realised that every time i connect gui to a specific key the items drop immediately from that gui after i put them in and i cant connect gui to an armor. Any ideas? I've searched on the forum but cant find anything 100% related.

Last seen on 03:10, 21. May 2022
Joined Apr 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Hello viatrophy997   I had a…
Wed, 03/24/2021 - 22:38

Hello viatrophy997

 

I had a similar issue, and that was because I was using a procedure to open the GUI, how I fixed it is, on the item itself, go to the tab that says "Inventory" and use the drop down menu next to where it says "Bind this item to GUI" and select your GUI. Also in the GUI editor, open each slot and untick the box that says "drop items that are not bound to an external inventory"

Last seen on 16:07, 12. May 2021
Joined Mar 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
The problem is that there is…
Fri, 03/26/2021 - 11:40

The problem is that there is no tab for it because it is an armor piece so i can bind it only with procedures or fake blocks.