I need help, When I go in to a custom dimension the game crashes! [Solved]

Started by eDdniom on Mon, 06/14/2021 - 22:15

Topic category: General discussion

Last seen on 09:55, 18. Jul 2021
Joined Oct 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I need help, When I go in to a custom dimension the game crashes! [Solved]
Tue, 06/15/2021 - 16:36 (edited)

I am working on a mod for a few months now, and today when I made new elements when ever I go in to a custom dimension the game crashes, I tried removing the new things I added but I can't find the solution myself, so If anybody can help me, please help!

 

https://imgur.com/a/gFAp0dQ <-- Console Error

 

If you need more information, just ask.

Edited by eDdniom on Tue, 06/15/2021 - 16:36
Last seen on 11:00, 24. Jul 2021
Joined Apr 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
    Hmm... Try making a new…
Tue, 06/15/2021 - 07:35

    Hmm... Try making a new dimension with same properties(fog, generation type, same biomes)and remove the old one. Mostly works for me if something similar happens.

IF IT STILL DOESNT WORK, ASK! ILL THINK ABOUT THIS VERY SERUASLY...

Last seen on 09:55, 18. Jul 2021
Joined Oct 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Hello, I tried making a new…
Tue, 06/15/2021 - 08:26

Hello, I tried making a new diimension with the same properties without making structures generate there and when I entered the new made dimension it still crashes, I tried regenerating the code but that still did not work.

Last seen on 09:55, 18. Jul 2021
Joined Oct 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I started removing my custom…
Tue, 06/15/2021 - 09:36

I started removing my custom biomes from my dimension, and found out that one of the biomes makes the crash, witch is weird since I haven't added anything new to that biome for almost 5 weeks and It worked just fine.

Last seen on 09:55, 18. Jul 2021
Joined Oct 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Hey, I found the problem one…
Tue, 06/15/2021 - 10:19

Hey, I found the problem one of the mobs had a trigger on spawn which wasn't supposed to be there and caused the game to crash, but thanks for the help if it wasn't for you I wouldn't have looked there!

Last seen on 11:00, 24. Jul 2021
Joined Apr 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
   No problem.   But you can…
Tue, 06/15/2021 - 19:43

   No problem.

 

But you can fix the game crashing with a "Wait" brick..

It also crashes "On initial Entity Spawn" when a command Is executed.. (/say hi)


►Example(not working): https://ibb.co/hK94QyF

►Example(working): https://ibb.co/JjQjG4N