"Scamming" problem (help me)

Started by GioMikeRafto on Sun, 08/15/2021 - 21:54

Topic category: Help with modding (Java Edition)

Last seen on 09:27, 15. Sep 2021
Joined Sep 2018
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
"Scamming" problem (help me)
Fri, 08/20/2021 - 20:33 (edited)

I have followed the tutorial from NorthWestTrees gaming video and have managed to open the gui but, the trades don't work properly. When I put an emerald on the input slot, the output items may not appear unless the player places 2 or more emeralds one by one. When 1 emerald is placed, the player can then take as many items as he wishes until the output item finally decides to show up and then all things work properly. When 2 emeralds are placed one by one, it is afted the second one that the output items appear, and then everything works fine. Can someone help me on this matter?

I am not sure if this is a bug or not, but I don't know what I am doing wrong (let me know if this happens to you as well)

Here are some pictures:

(The procedures as the same ones from the video)

Edited by GioMikeRafto on Fri, 08/20/2021 - 20:33
Last seen on 09:27, 15. Sep 2021
Joined Sep 2018
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Can someone please help?  
Mon, 08/16/2021 - 19:42

Can someone please help?

 

Last seen on 09:27, 15. Sep 2021
Joined Sep 2018
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
This may be a bug, that's…
Wed, 08/18/2021 - 18:21

This may be a bug, that's why I posted it on github.

 

But there is no response from anyone