Problem when not using armour texture

Started by ImNotFun on Wed, 08/18/2021 - 03:31

Topic category: Help with MCreator software

Last seen on 12:33, 23. Oct 2021
Joined Sep 2019
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Problem when not using armour texture
Wed, 08/18/2021 - 03:31

When I try to apply my textures to a custom helmet and chestplate model, the helmet texture doesn't apply correctly.

This is what the helmet is meant to look like:

Helmet meant to look like thistextures

But in-game it looks like this:

Looks like this in-game

For both the chestplate and helmet I am using separate textures, and while the chestplate's texture works just fine the helmet texture is all messed up. I've tried combining the textures into an armour texture (which messed up the textures of both pieces of armour) and rotating the texture of the helmet but so far nothing has worked.

Does anyone know how to fix this?