Crash when I click New World

Started by Shrek420 LOLOLOL on Thu, 12/30/2021 - 06:48

Topic category: Help with modding (Java Edition)

Last seen on 14:14, 13. May 2022
Joined Nov 2019
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Crash when I click New World
Thu, 12/30/2021 - 06:48

Whenever I click Create New World, the game shows "Saving world" for a moment then crashes. I don't know why this is happening, but it only just started after changing a sound in a custom biome. The console doesn't help, it's vague and full of junk.

Console: https://pastebin.com/TsXiepte

Can somebody look through this chaos and decode what the heck this means? Thanks, you're my only hope.

Last seen on 14:14, 13. May 2022
Joined Nov 2019
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I ended up deleting the…
Thu, 12/30/2021 - 07:25

I ended up deleting the original biome I changed the sound effect of and it's still happening WHAT AM I SUPPOSED TO DO

Last seen on 21:20, 24. May 2022
Joined Dec 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Try regenerating the code…
Thu, 12/30/2021 - 14:46

Try regenerating the code. You can do that by clicking the bandage next to the hammer. Hopefully that fixes it or you can find the problem.

Last seen on 14:14, 13. May 2022
Joined Nov 2019
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Hold on lemme try
Thu, 12/30/2021 - 15:00

Hold on lemme try

Last seen on 14:14, 13. May 2022
Joined Nov 2019
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Regenerated code, problem…
Thu, 12/30/2021 - 15:06

Regenerated code, problem still happening, hope that I didn't just waste half a year making a mod that ended up breaking is waning.

Last seen on 21:20, 24. May 2022
Joined Dec 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Try deleting the biome…
Thu, 12/30/2021 - 15:09

Try deleting the biome entirely. Other than that I don't know what to do for you.

Last seen on 14:14, 13. May 2022
Joined Nov 2019
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I deleted the biome I…
Thu, 12/30/2021 - 15:17

I deleted the biome I changed the sound of before I made the post. I have barely any hope anymore.

Last seen on 21:20, 24. May 2022
Joined Dec 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Then. I don't know.  
Thu, 12/30/2021 - 15:21

Then. I don't know.

 

Last seen on 14:14, 13. May 2022
Joined Nov 2019
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I swear to god if I lose my…
Thu, 12/30/2021 - 15:38

I swear to god if I lose my entire mod to this goddamn crash I'm gonna lose my sanity.

Last seen on 09:54, 12. Jan 2022
Joined Nov 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
On the biomes, what settings…
Fri, 12/31/2021 - 14:23

On the biomes, what settings did you do? did you increase the tree size beyond 30? as I remember, anything beyond 30 will cause that, also did you set the biome tags properly?

I've experience that same crash when I made by custom biome for my Titans mod

Last seen on 14:14, 13. May 2022
Joined Nov 2019
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
it was working perfectly…
Sat, 01/01/2022 - 13:46

it was working perfectly fine before I changed the sound of a biome

now the biome I changed the sound of is deleted

Last seen on 14:14, 13. May 2022
Joined Nov 2019
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
figured it out 2021.3 + big…
Sun, 01/02/2022 - 17:19

figured it out

2021.3 + big spruce tree = :(

Last seen on 17:23, 27. May 2022
Joined Dec 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Yes, this element in…
Mon, 05/02/2022 - 18:32

Yes, this element in mcreator 2021.3  are corrupted :(