"Villager Trade" Option Hard Locking my Mods out of being Playable via Safe Mode

Started by BNTrash on Thu, 05/12/2022 - 04:01

Topic category: Help with MCreator software

Last seen on 05:02, 28. May 2022
Joined May 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
"Villager Trade" Option Hard Locking my Mods out of being Playable via Safe Mode
Thu, 05/12/2022 - 04:01

Yes. I mean exactly that. I made another forum topic about this, but no attention was paid to it and I know a lot more about what's wrong then when I made that. Basically I have lost a mod I had been working on for a total of many months, and now a partial recreation was lost due to the same thing. Villager Trades. They seem to permanently trigger the whole safe mode thing, even after deleted. I have tried doing a lot of things other forum posts have said to try when it comes to safe mode, and none of them fix it. I am in desperate need of some assistance and/or feedback on this matter/bug.

Making another topic won't…
Thu, 05/12/2022 - 11:12

Making another topic won't help you, being precise in your issue will. Please reproduce steps you took.

As for "safe mode", it is usually happening when you apply something that overrides vanilla data in a way that it can corrupt the world. If deleting villager trade doesn't help, the issue can have different reason, sometimes this can be really small and stupid thing. Most of those are on user's fault though, since such big feature couldn't go untested to such extent.

Last seen on 05:02, 28. May 2022
Joined May 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I can tell you with a 100%…
Sat, 05/14/2022 - 19:38

I can tell you with a 100% certainty this is being triggered by Villager Trades, because everything else I've done is 1. done separate, and by that I mean the only thing I added between the prior test and the first test that triggered safemode, was villager trades. Nothing else was changed. And 2. Been done before in prior builds of my mods, and caused no problems of this sort in the past, and in current build still doesn't.