Server-Side Mod Checkbox Does Not Work

Started by DaGooRoo on Mon, 05/30/2022 - 21:47

Topic category: Troubleshooting, bugs, and solutions

Last seen on 00:32, 3. Jun 2022
Joined May 2022
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Server-Side Mod Checkbox Does Not Work
Mon, 05/30/2022 - 21:47

Seeing as the older posts related to this issue haven't been commented on at all, I'll make a fresh one to get some new eyes on the problem.

The issue is with the server-side functionality. A couple other users seem to have encountered this same issue. If one wants to make a mod that strictly deals with data and commands, it simply will not work only on the server side. Furthermore, it also does not work if you attempt to create a server-side mod and a client side mod that work in tandem, without both the server and the client having a copy of each. 

I have received errors when attempting to connect to my server that included 'mismatched mod id' and 'incompatible mod versions,' despite having the server-side mod box checked and the forge version tracker disabled. 

My server config files are all set up to disable forge and mod version checking so as to better suit the mod, but even taking these steps does not fix the issue. 

It would greatly benefit the utility of this mod creator to fix this bug or post a workaround so users' mods are not restricted in their utility. 

Many thanks to the amazing work put into this project, the bugs are few and far between, overall an outstanding product. 

This is normal as UI…
Tue, 05/31/2022 - 06:12

This is normal as UI elements like checkbox and text field are not server-synced yet.