Gradle fails to build

Started by The Reboot on Thu, 08/25/2022 - 20:21

Topic category: Troubleshooting, bugs, and solutions

Last seen on 22:14, 31. Aug 2022
Joined Aug 2022
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Gradle fails to build
Thu, 08/25/2022 - 20:21

I've looked at a couple of forms where people claim to have a similar problem, but none of the suggested solutions I've tried have worked.

When I begin to build the workspace or try to import any files or create any new things in my mod, I get an error message saying that one of my main mod files didn't compile properly. Clicking "Regenerate code" doesn't help it at all and gives me the same message. I'm not sure if there's anywhere I can access the error logs for this which I could share if there is, but I'm not really sure what to do anymore. I've tried relaunching the program, restarting my computer, creating a new workspace and then moving back to this one, none of them seemed to work. I've gotten this error a few times, but usually it fixes itself after I relaunch it or restart my computer, this time it won't. I'm not sure if it's caused by how I'm closing the program or not, sometimes I click "Exit MCreator" and others I just click the "X" at the top right. Could anyone help please?