Workspace not loading on 1.18.2

Started by Mariano Argüello on

Topic category: Troubleshooting, bugs, and solutions

Last seen on 17:20, 2. Sep 2023
Joined Feb 2016

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
Workspace not loading on 1.18.2

Hi. I've been having an issue since MCreator 2022.3 was released some time ago. When i load my workspace, the same "Mcreator detected Gradle caches got corrupted". When i remove the caches folder to regenerate it, it comes right back at me at the next build! Also sometimes i get the "MCreator Workspace setup failed", but i do the exact same thing and nothing changes. Recently i tried switching to 1.19 to see if the problem will persist. And it looks like the error message doesn't show up for me. I then updated to 2023.1 and this still happens to me.

I tried creating 2 brand new workspaces and the 1.18.2 one always fails on the initial build, but the 1.19 works normally. So it seems like for me the 1.18.2 generator is broken. I don't know if anybody experiences this, but if it's a bug i hope it can be fixed soon. I'll try updating MCreator when the new 1.19.4 generator goes live soon, hopefully that new version fixes the issue with 1.18

If anyone has any idea on why this keeps happening to me, i invite you to comment on this thread, since i wanted to port my mod from 1.16.5 to 1.18 but now i only can upgrade to 1.19. Cheers

PD: If you wanna replicate this issue, create a workspace in both version generators. If my MCreator is working normally, that should be enough to see the error pop up. Also it seems like some libraries or certain files are failing to download when using the 1.18 generator, and that's the reason it keeps failing to compile the workspace. But after looking in the Knowledge Base, this should be fixed by removing the caches and re-generating them. Again, that doesn't work for me. I have an internet connection of 4 mb (up) and 0.2 (down). But i never had issues with my net connection. Could that be the issue now?