"Place structure" block doesn't run when generating new terrain

Started by 91arrows on

Topic category: Troubleshooting, bugs, and solutions

Last seen on 18:45, 9. Nov 2023
Joined Jul 2017

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
"Place structure" block doesn't run when generating new terrain

i'm making a complex structure with randomly generated parts, like a village or an ancient city.

i executed this idea by:

  1. first, building all the individual parts / rooms and saving them as nbt files
  2. then, making a procedure that places down all the individual parts / rooms
  3. then, going into minecraft and saving an empty structure consisting of only air blocks
  4. then, adding the empty structure as a structure element
  5. then, making the aforementioned procedure execute when the empty structure is generated

so essentially i have an empty structure, and when that structure is generated, it executes the procedure and places all the different parts. this theoretically should result in a big complex structure with randomly generated individual parts.

when i tested it in minecraft, the structure did not show up. i set the empty structure to spawn 500,000 times per 1,000,000 chunks by the way.

i tried to debug the procedure by adding a few "place block" blocks to the procedure. when i tested it in minecraft, those blocks did actually show up, which shows that the procedure was actually happening, but the structure parts weren't showing up.

so i have concluded that it is specifically the "place structure" block that does not work. i tried to debug that by making a test block, and when you place down that test block, it would place a structure. that worked fine, showing that the "place structure" code block does work.

so that shows that specifically the "place structure" block doesn't work when minecraft is generating new terrain. when the terrain has already been generated and you're placing a structure onto loaded chunks, the "place structure" block works fine, but it just doesn't work when you're trying to place a structure in an unloaded chunk.

i will also accept workarounds. or if you know how to make jigsaw blocks work in mcreator, i will accept that as well.