Saved Instances error with mobs.

Published by Chemma2B on Mon, 07/02/2018 - 07:07
Status
Fixed
Product/platform
Not applicable
Priority
Normal
Issue description

I have a problem once i've saved a mob and i try to edit it again, it says it does not have a saved instance and if i want to edit again i'll have to remake it.(I'm using a custom model from tabula and a self-made texture) Also causes an error when i try to export it into a mod file, oddly it doesn't come up under problematic mods (gradle log attached).

The list of things i've tried:

Clicking the gear on the bar, nothing.

Changing workspaces, nothing.

Uninstalling and reinstalling mcreator, nothing.

Trying it in 1.7.8, i can then go back and edit the mob, but same outcome when trying to export it (Shows up in problematic mods though).

Using more than one mob, nothing.

Using vanilla textures and models, nothing.

Using a different PC, nothing.

Using an AI base, nothing.

I'm using a windows 10 system, please let me know if you need any more information. Thanks for your time.

Attachment Size
Error when exporting to mod file.28.45 KB 28.45 KB

Issue comments

Importing newer workspace in older versions of MCreator will not work.

Could you attach your workspace so I can test it myself?

If it shows problematic mods, it means that the model from tabula contains errors and this is not related directly to MCreator as we don't provide support for third-party tools on this issue tracker.

Sorry for the late response, it's from the same version mcreator, and once i tried a model other than tabula it worked. Thanks so much, let me know if you still want the workspace.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.