I can't install any version of MCreator!

Status
Fixed
Type
Product/platform
MCreator/Windows
Priority
Normal
Issue description

Please help me! When I open MCreator and try to install it it gives always an error and writes:

   
Executing gradle command: cleanCache clean setupDecompWorkspace --refresh-dependencies
Microsoft Windows [Version 10.0.16299.611]
(c) 2017 Microsoft Corporation. Alle Rechte vorbehalten.
C:\Pylo\MCreator176>cd forge
C:\Pylo\MCreator176\forge>SET "JAVA_HOME=C:\Pylo\MCreator176\jdk64\"
C:\Pylo\MCreator176\forge>SET JAVA_EXE=%JAVA_HOME%\bin\java.exe
C:\Pylo\MCreator176\forge>SET PATH=%JAVA_HOME%\bin\;%PATH%
C:\Pylo\MCreator176\forge>gradlew -Dorg.gradle.jvmargs="-Xms625m -Xmx2048m" cleanCache clean setupDecompWorkspace --refresh-dependencies 
This mapping 'snapshot_20170624' was designed for MC 1.12! Use at your own peril.
#################################################
         ForgeGradle 2.3-SNAPSHOT-ee3e3df        
  https://github.com/MinecraftForge/ForgeGradle  
#################################################
                 Powered by MCP                  
             http://modcoderpack.com             
     by: Searge, ProfMobius, R4wk, ZeuX          
     Fesh0r, IngisKahn, bspkrs, LexManos         
#################################################
:cleanCache
:clean UP-TO-DATE
:deobfCompileDummyTask
:deobfProvidedDummyTask
:getVersionJson
:extractUserdev
:extractDependencyATs SKIPPED
FAILURE: Build failed with an exception.
:extractMcpData
* What went wrong:
BUILD FAILED
Could not resolve all dependencies for configuration ':forgeGradleMcpData'.
> Could not resolve de.oceanlabs.mcp  Required by:
:mcp:1.12.2.
      com.yourname.modid:forge:1.0
Total time: 51.934 secs
> Could not resolve de.oceanlabs.mcp:mcp:1.12.2.
> Failed to download SHA1 for resource 'http://files.minecraftforge.net/maven/de/oceanlabs/mcp/mcp/1.12.2/mcp-1…'.
> For input string: "* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
C:\Pylo\MCreator176\forge>
Task completed with return code 0 in 54092 milliseconds

Please help, because idk what to do... Thanks!

 

Issue comments

This error can be caused by:

  • Slow internet connection
  • Firewall or antivirus blocking MCreator
  • ISP blocking certain websites
  • Any other software blocking access to download repository

As you are using an older version of MCreator, it could also be that the repository does not exist anymore. I suggest you to use a newer version of MCreator.

No... It didn't work! Any of the programms were blocked and I downloaded the latest version of MCreator... Also the Internet was like always good, but still gives the same error...