Procedure Maximum Issue/Bug!

Published by KreatorB on Sat, 10/20/2018 - 12:44
Works as designed
Not applicable
Issue description

I was excited to get my internet back up an running today and figure I could finally start working on my mod pack again.
However when I started with creating my 11th procedure and tried to use it , it was no where to be found.

So I figured that this might be a glitch, so I restarted, check the prefs, and deleted the old procedure and tried again....

But it changed not, the 11th procedure does not show up, is there a way to have more then 10 procedures?

Attachment Size
shows available procedures287.85 KB 287.85 KB
shows listing509.37 KB 509.37 KB
test.png326.41 KB 326.41 KB

Issue comments

There most certainly can be as many procedures as you want. The issue is that one of your procedures requires dependencies that are not provided by all triggers and these procedures are not shown on the list.

not sure I understand, the procedure is a simple block replace like all others I have. No different then any others I created... 

I have tested your procedure and as I said previously, it is as it works (works as designed). Check this image:


As you can see, the procedure requires itemstack, but the trigger you are using does not provide itemstack so the procedure is not listed on the list.

okay so all that is caused by the deal the provided item damage amount! So how do I add damage to the item that I am using?


You can't damage item when right clicked on the block as this does not work this way in the code. Not all items can be damaged. If there would be no limits there would be no need to even introduce the dependency system with procedures.

Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.