Graddle Task Failed?

Published by Luizlolmen on Tue, 11/06/2018 - 13:53
Status
Fixed
Product/platform
MCreator/Windows
Priority
Normal
Issue description

I've got this problem with the new version of MCreator, just as I've started him, when comes to the part “Caching decompiled code” appear “Gradle task failed” the funny thing is that I've been getting the same error with the 1.8.0 version after 167 mod elements, but in that case the error occurred when try to start the client

  
Executing gradle command: cleanCache clean setupDecompWorkspace --refresh-dependencies
Build info: MCreator 1.8.1, 64-bit, 3583 MB, Windows 8.1 - cmd, JVM 1.8.0_172, JAVA_HOME: C:\Pylo\MCreator181\.\jdk
(c) 2013 Microsoft Corporation. Todos os direitos reservados.
C:\Pylo\MCreator181\forge>gradlew -Dorg.gradle.daemon=false -Dorg.gradle.parallel=false -Dorg.gradle.jvmargs="-Xms625m -Xmx2048m" cleanCache clean setupDecompWorkspace --refresh-dependencies 
Etag download for http://files.minecraftforge.net/maven/de/oceanlabs/mcp/versions.json fa…
Etag download for http://export.mcpbot.bspk.rs/versions.json failed with code 400
Etag download for http://files.minecraftforge.net/maven/net/minecraftforge/forge/json fai…
FAILURE: Build failed with an exception.
* Where:
Build file 'C:\Pylo\MCreator181\forge\build.gradle' line: 24
* What went wrong:
A problem occurred evaluating root project 'forge'.
> No such version exists!
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
BUILD FAILED
Total time: 1 mins 36.405 secs
C:\Pylo\MCreator181\forge>
Task completed with return code 0 in 99459 milliseconds

Issue comments

Sorry, my bad, actually the error occur when “Setting up Minecraft Forge MDK”

 

I suggest you to go your user folder, go into .mcreator folder and delete gradle folder inside this folder. Then uninstall MCreator and install it again. Make sure that you have MCreator allowed in Firewall and Antivirus and that nothing is obstruction MCreator from downloading the files.

Nothing worked, and I've tried everything you suggest and even some others things like trying to run the 32x version (which says that don't have enough RAM to run and say to edit the RAM options, but I can't edit because appear the error overlay, which I can't close without closing or relaunching the Mcreator), and run with compatibility on, nothing worked thou



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.