Disable forge version limit

Published by Conflee on Fri, 02/01/2019 - 21:37
Issue description

Previously mods I made worked within the newest Forge (forge- but with the 1.8.2 Update mods I make now refuse to launch saying I need to use an older Forge ( Somehow the newest MCreator has downgraded the forge versions its usable in.


As extra detail, 2808 is the highest/newest Curse lets me use so thats why I'm using it. 

Issue comments

From 1.8.2 changelog:

  • Added Minecraft Forge with version tag as mod dependency when exporting

In MCreator 1.8.2 we have added Minecraft Forge version tag as a dependency as many users used MCreator with different versions Minecraft Forge than with the one MCreator used to compile mods. This caused many crashes and errors due to version mismatches. We added this dependency to resolve this issue.

MCreator uses Minecraft Forge 2768 from version 1.8.1 onwards (https://mcreator.net/changelog). We always use the latest recommended version by the Minecraft Forge developers which is 2768 at the time of writing (http://files.minecraftforge.net/).

We could add an option to exclude this requirement in 1.8.3, but if there is not enough demand we prefer not to for the reasons given above.

Most of the people I know on the internet using Mcreator are doing it to add their own ideas to minecraft for personal use. That's what i'm doing, and If I choose a different version of forge (...75 instead of ...68) Then it should be up to me if I want to build for that version of forge dependancy. I've been searching for a way to change Mcreator's forge version for days now, ever since converting to 1.8.2 I can't even make mods for my personal pack anymore, so I have no use for Mcreator. Terrible shame, and you definitely should add that compatibility for the people that need it.

We had a good reason to do this, as we got way too many bug reports with crashes related to Forge incompatibility.

If your other mods don't support this version, they are the same part of the issue as MCreator mods.

There is no option to disable this check in 1.8.2, at least not a simple way. You can do this manually, though.

You only need to do this when you want to export your mod:

One way is to change this part of the code from file forge\src\main\java\mod\mcreator\yourmodid .java (replace yourmodid with your actual modid):

@Mod(modid = yourmodid.MODID, version = yourmodid.VERSION, dependencies = "required-after:forge@[]")


@Mod(modid = yourmodid.MODID, version = yourmodid.VERSION)

Then you need to run build without MCreator overwriting your files, which you do by going to console tab and pressing console icon in the toolbar (below gears icon). When a popup opens, leave default option (build) and press OK. Wait for Gradle to build your customized code. If you would just recompile the mod, MCreator would overwrite your change, so you need to run manual gradle build as instructed above.

After the build is complete, go to forge\build\libs  and copy file modid-1.0.jar somewhere else and rename it to the desired jar name of your manually exported mod.

I just reinstalled the program to try to fix this. I just now got the link to see this through emailing support a few days ago!


Thanks MCreator so much if it works! Will let you know what happens

Just tried this and am not sure if I did it wrong as it is not working.

I had to do it 3 times in order for it to work correctly.


Sorry for the spam comments,


We will add an option to disable this check in MCreator 1.8.3 in workspace settings. I am closing this ticket.

You have a workaround written a few lines above. If you don't understand it, you are better off using default settings as we won't give you any support if you decide to use unsupported forge versions.


@Mod(modid = yourmodid.MODID, version = yourmodid.VERSION)



@Mod(modid = primale_age.MODID, version = primale_age.VERSION)

@Mod(modid = primale_age.MODID, version = primale_age.VERSION, dependencies = "required-after:forge@[]")

@Mod(modid = primale_age.MODID, version = primale_age.VERSION,

@Mod(modid = primale_age.MODID, version = primale_age.VERSION, dependencies =

I have teird all of these evean using mobid

MCreator 1.8.3 will support this without changing the code. And if you don't understand the code you shouldn't be changing this anyways most likely.