Importing JAVA Model Bug

Status
Works as designed
Type
Product/platform
Not applicable
Priority
Normal
Issue description

I don't know if anyone else has had an issue but, when I import my custom-ly made models(in Blockbench) they do not get added to the resource tab. I don't know if this is a blockbench or mcreator bug as when I imported a silverfish model, it got added. 

Attachment Size
The file I tried to import.1.95 KB 1.95 KB

Issue comments

You most likely have one model with the same name already imported. In the Java code, your model is called unknown. If you add another model with the same name, it will only overwrite the current one.

So you mean if I have a model with the same name it'll get overwritten? I f so, no as I had tried this multiple times each new model with a different name.

I only have 1 custom model available and had 2 in 1.8.1. I'm not sure what to do.

MCreator 1.8.2 uses a different concept with global model storage, this is why it stopped to work like this now.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.