Creative Menu Order breaks most mod elements

Published by Aethelwyn on Thu, 03/26/2020 - 13:12
Status
Can not reproduce
Type
Product/platform
Not applicable
Priority
Normal
Issue description

I decided to make some changes to the Creative Menu ordering partway through the development of my mod. & It has definitely caused some issues.
Some things of Note:

  1. Textures became mismatched on almost all blocks & items (Only ones that didn't were ones with custom models)
  2. Some recipe types switched back to Crafting from Stone Cutter
  3. Blocks with a Wall blockbase became a Slab
  4. Blocks with a Slab blockbase became a Normal Block
  5. ItemGroup Icons could not read any textures for icons
  6. Most procedures that had to do with blocks & items mismatched
  7. The Compilation errors we're seemingly random in what they were for
  8. Dimensions without a portal created a pseudo-item, one that could not be seen in game, but was visible in MCreator
  9. Advancement Icons could not read any textures for icons
  10. Regenerating Code Base or Source Files did nothing

I didn't get a chance to pick at it more because the workspace had seemingly disappeared on a fresh restart this morning

Issue comments

This could not happen simply due to switching creative menu ordering unless you forcefully closed MCreator in between and even this could not cause this.

What do you mean by the workspace disappeared?

Workspace is a whole folder of files and it can't really just disappear.

I would need a bit of more context and workspace, without it I can't really find the real cause.

I have made 5 test workspaces and imported one with around 2000 elements and tried reordering tabs on all of them and was not able to reproduce this, unfortunately.

Perhaps it was just a one time bug?

Trying it a few times again hasn't reproduced the issue
All I remember from last night is changing the creative order of almost all blocks to be more orderly & that not long after everything that had some form of texture attached to & most procedures connected to those elements had compilation errors.

However I did notice that the github repository I've been syncing my changes to is completely empty, even though I am certain I have synced changes in that mod to it.

I'm still not certain on what happened to the local workspace folder, It's not in it's directory & not in Trash. Possibly just an issue with my Linux Distro

Sorry for using up your time, in hindsight I probably should've tried to reproduce it beforehand

However I did notice that the github repository I've been syncing my changes to is completely empty, even though I am certain I have synced changes in that mod to it.

Probably Git caused this because Git can do some nasty things to JSON with auto merging, especially if you try to sync different versions of MCreator.

All I remember from last night is changing the creative order of almost all blocks to be more orderly & that not long after everything that had some form of texture attached to & most procedures connected to those elements had compilation errors.

When you get random compilation errors, first suspect this: https://mcreator.net/wiki/gradle-setup-errors#wiki-index-13

Which distro do you use btw, so I can do some further testing on it if I get time?
 

Linux Mint 19.3 Cinnamon



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.