Custom Entity Model cannot hold tools/items

Published by charwick on Sun, 03/29/2020 - 00:33
Status
Works as designed
Type
Product/platform
MCreator/Windows
Priority
Normal
Issue description

I tried giving a custom entity, with a custom model, a sword and it doesn't show up in game. If this issue can be solved somehow, please email me and let me know how to go about this

Issue comments

You need to define holding positions and item renderer for a custom model for this to work. For this, you need some Java knowledge, though.

Thank you for the very quick reply, although java knowledge is required can we expect this to be a feature anytime soon? I have little to no coding skills and would love to have custom entities holding items.

This is a feature of modeler, we just support Java model importing.

But we might make our own modeler in the future, who knows ;)



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.