Location procedures not working with GUIs without slots

Upvotes: 1
Issue description

I have a procedure set up so whenever I click on certain buttons in my gui each one plays a different sound (in my case it's music), and whenever I click on those buttons in the gui they do nothing, all the other buttons in the gui work perfectly. I attached a screenshot of the procedures, here is a link to download the workspace beacuse it is too big for the attachments : http://www.mediafire.com/file/sg4fk0sgse0h5ge/iphonetest.zip/file

Attachment Size
Screenshots of procedures.193.15 KB 193.15 KB

Issue comments

Edit these buttons and reselect the procedures to update the dependencies. Please report back if it helped.

It didn't help, I also tried making new procedures and new buttons but it still doesn't do anything.

The actual cause for this bug seems to be this: Location procedures not working with GUIs without slots

I changed the ticket title to reflect this. This bug will be fixed in MCreator 2020.3.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.