MCreator for MINECRAFT 1.12.2

Published by DENTiller on Sat, 04/18/2020 - 16:18
Status
Won't fix
Product/platform
MCreator/Windows
Priority
Normal
Issue description

Hello Developers of MCreator!
I would like to write opinion on indicating the version of Minecraft 1.12.2 as outdated.
For me, this is wrong, Minecraft 1.12.2 is one of the most popular versions of minecraft that comes with a lot of mods and various projects.
If you stop supporting your program for Minecraft 1.12.2, then most likely there will be a tsunami of negative comments from users.
I myself am not happy with this news.
But still I hope that you will take into account my message and will do support not only for new versions of minecraft, but also for 1.12.2.

If this does happen, then I will lose my projects and other users of your program too, because there will be no new updates with new features and bug fixes. At the moment, I have already spent a lot of time on MCreator and got a lot for myself, and I can say that you should pay more attention to your program, because it has few important things and a lot needs to be fixed, and it will be very sad if you You will not support Minecraft version 1.12.2.
Regards DENTiller.

Issue comments

We will have to drop support for Minecraft sooner than we expected. MCreator 2020.2 will be the last version to support Minecraft 1.12.2. The reason for this is that we will have to update to Java 8u252 which is unsupported by Minecraft 1.12.2, but not updating Java versions can cause security issues that we do not want. We will have to move to Java 9+ in the future too and this version is not supported by 1.12.2 and never will be, but we are missing out with features and performance improvements due to not updating Java to version higher than 8. More on incompatibility with Minecraft Forge <1.12.2 and Java updates above 8u242 can be read here: https://github.com/MinecraftForge/MinecraftForge/pull/6473

Cited from https://mcreator.net/news/57594/first-20202-snapshot-and-website-update. Plus it seems you do not know what maintaining legacy unsupported code means for the developers.

If there is really that much interest for 1.12.2, I believe there will be someone who will make a plugin for it, but official support is dropped.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.