1.12 Slab Bug

Published by KreatorB on Mon, 04/20/2020 - 14:26
Status
Resolved
Type
Product/platform
MCreator/Windows
Priority
Normal
Issue description

Slabs Recipes not WORKING in v1.12

If I am not mistake, when I made the move to 2020.2 I tested the slabs and recipes I believe worked!
I also tested my 1.12 version in 1.14 by converting the workspace and the problem still occurred.

In the 1.14 version I created a new slab and recipe and they seemed to work! However I got it to work in 1.14 by opening the old recipe that was created in workspace  1.12 and saving it over again. That seemed to activate it. However the 1.12 workspace does not work, even if I create a new recipe or re-save an old one.

I tested a new workspace for 1.12 and it seems that the issue of the recipe is 1.12 with slabs only!
 
I also took a copy of a working slabs in workspace 1.14 and converted back to 1.12 and that did not work either.

So it seems that the recipe for Slabs in 1.12 seem to be buggin.  

Hope These details help. Let me know if you need a copy of my files and how to send them!

 

--------------------------------------------------------------------------------------------------------

I am providing you the steps to help in the issue reproduction!

 
1. Create a new workspace v1.12

2. create or import 2 textures to test with

3. create a block with one of the textures

4. create a slab with the other texture

5. create a recipe for the slab

6. run client to test

7. check to see if recipe works in game version 1.12

8. If you like convert the 1.12 version to 1.14 and test in there.

9. If you do, converts slab recipes will function and if they do not you may need to open a few and re-save them is all.

 

I really hope this helps and that you will find it in your power to help fix this bug for the users/community of version 1.12 as this is the missing piece in the long await part of the puzzle.

Once again Thank you for understanding and helping.

Please let me know if you require anything that I can provide to make this bug go away!

THANKS

Issue comments

This is a known problem. Unfortunately, 2020.2 is now complete release, while 2020.3 is the next release candidate.

It will not officially support 1.12.2 so this is now on the community to make a plugin fixing this if desired.

I am sad this bug was not discovered while there were 2020.2 snapshots so we could fix before 2020.2 release.

My best advice would be to move to 1.14.4.

I have come across a potential fix/work around.

Using the following Mods for 1.12 which are found on https://www.curseforge.com/minecraft/mc-mods/

You will be able to add them to your gradle/run folder and create the recipes needed.
A file will be created under the gradle/scripts folder and the file will house all the recipes for your users.

However you will need to make sure that you add to the API/External MOD requirements that this mods are required and the script file is also required. While this sucks butt, it is the only way to now fix the final slab stages of the 1.12.2 of MCreator app as the support is not gone for 1.12.

 

Hope this helps

KreatorB

 

 

I have found an alternative fix. Lock code of recipes with slabs and add data attribute, for example:

{
  "group": "project",
  "type": "minecraft:crafting_shaped",
  "pattern": [
    "0"
  ],
  "key": {
    "0": {
      "item": "minecraft:tnt"
    }
  },
  "result": {
    "item": "project:customslab",
    "count": 1
  }
}

change it to:

{
  "group": "project",
  "type": "minecraft:crafting_shaped",
  "pattern": [
    "0"
  ],
  "key": {
    "0": {
      "item": "minecraft:tnt"
    }
  },
  "result": {
    "item": "project:gfdhk",
    "data": 0,
    "count": 1
  }
}

Same would go for input, just add data tag below it.

This is a strange system with this "0" hack only seen in 1.12.2 (due to migration from metadata to the new flattened system in later versions) and thankfully removed in later versions of Minecraft.

So open recipe of slab add "data": 0, to recipe and done.
Thank you, will try this.

You refer to input, in that in the slabblock?

thank fort the help

THANK YOU, that is so stupid that a data:0 fixes the issue. will be a long an painful fix. But it is a fix and I thank you for finding a simple solution and not relying on other mods!

worked perfectly

Just to reply to this thread as I think plenty of others will end up here...... the data tag workaround works for slabs as an output, but to get the slabs as an INPUT into all other slab recipes some other changes would be needed inside a tag code adding the slabs to the OreDict slabWood. So far I have not been able to figure out how to update that code to get it to work, and the slabs are not recognised as ingredients. Just adding a metadata ", 0" to the itemstack doesn't appear to work there. So if anyone has figured out that part please share.

 



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.