Procedures do not work in the new snapshot.

Published by 9678Dash on Sun, 04/26/2020 - 01:50
Status
Can not reproduce
Type
Product/platform
MCreator/Windows
Priority
Normal
Issue description

Hello, It would seem as if procedures do not work in the new snapshots. Hopefully this can be fixed.

EDIT: For clarification, I can open the procedure editor, but it seems like it never loads. I can't add any procedure blocks while in this state, and all I can do is save.

Issue comments

  1. Do you have any plugins loaded?
  2. Did you try restarting MCreator?
  3. What are the contents of mcreator.log?

Oopsies, apparently this issue is happening with ALL versions of mcreator installed on my pc. I have to idea as to why it is, but oh well.

Here is my mcreator.log file:

2020-04-27-20:43:51 [main/INFO] [Launcher] Starting MCreator 2020.2.13719 - 202000213719
2020-04-27-20:43:51 [main/INFO] [Launcher] Java version: 1.8.0_232, specification: 1.8, VM name: OpenJDK 64-Bit Server VM
2020-04-27-20:43:51 [main/INFO] [Launcher] Current JAVA_HOME for running instance: C:\Program Files\Pylo\MCreator20202\jdk\jre
2020-04-27-20:43:51 [main/DEBUG] [Preferences Manager] Loading preferences from C:\Users\9678Dash\.mcreator\preferences
2020-04-27-20:43:51 [main/INFO] [Launcher] Installation path: C:\Program Files\Pylo\MCreator20202
2020-04-27-20:43:51 [main/INFO] [Launcher] User home of MCreator: C:\Users\9678Dash\.mcreator\
2020-04-27-20:43:53 [AWT-EventQueue-0/DEBUG] [Data List Loader] Added stepsounds datamap to cache
2020-04-27-20:43:53 [AWT-EventQueue-0/DEBUG] [Data List Loader] Added damagesources datamap to cache
2020-04-27-20:43:53 [AWT-EventQueue-0/DEBUG] [Data List Loader] Added biomes datamap to cache
2020-04-27-20:43:53 [AWT-EventQueue-0/DEBUG] [Data List Loader] Added potions datamap to cache
2020-04-27-20:43:53 [AWT-EventQueue-0/DEBUG] [Data List Loader] Added biomedictionarytypes datamap to cache
2020-04-27-20:43:53 [AWT-EventQueue-0/DEBUG] [Data List Loader] Added mapcolors datamap to cache
2020-04-27-20:43:53 [AWT-EventQueue-0/DEBUG] [Data List Loader] Added achievements datamap to cache
2020-04-27-20:43:53 [AWT-EventQueue-0/DEBUG] [Data List Loader] Added particles datamap to cache
2020-04-27-20:43:53 [AWT-EventQueue-0/DEBUG] [Data List Loader] Added blocksitems datamap to cache
2020-04-27-20:43:53 [AWT-EventQueue-0/DEBUG] [Data List Loader] Added keybuttons datamap to cache
2020-04-27-20:43:53 [AWT-EventQueue-0/DEBUG] [Data List Loader] Added sounds datamap to cache
2020-04-27-20:43:53 [AWT-EventQueue-0/DEBUG] [Data List Loader] Added tabs datamap to cache
2020-04-27-20:43:53 [AWT-EventQueue-0/DEBUG] [Data List Loader] Added enhancements datamap to cache
2020-04-27-20:43:53 [AWT-EventQueue-0/DEBUG] [Data List Loader] Added entities datamap to cache
2020-04-27-20:43:53 [AWT-EventQueue-0/DEBUG] [Data List Loader] Added gamemodes datamap to cache
2020-04-27-20:43:53 [AWT-EventQueue-0/DEBUG] [Data List Loader] Added materials datamap to cache
2020-04-27-20:43:53 [AWT-EventQueue-0/INFO] [Plugin Loader] Loading plugin: core from .\plugins\mcreator-core.zip
2020-04-27-20:43:53 [AWT-EventQueue-0/INFO] [Plugin Loader] Loading plugin: generator-1.12.2 from .\plugins\generator-1.12.2.zip
2020-04-27-20:43:53 [AWT-EventQueue-0/INFO] [Plugin Loader] Loading plugin: generator-1.14.4 from .\plugins\generator-1.14.4.zip
2020-04-27-20:43:53 [AWT-EventQueue-0/INFO] [Plugin Loader] Loading plugin: generator-datapack-1.14.x from .\plugins\generator-datapack-1.14.x.zip
2020-04-27-20:43:53 [AWT-EventQueue-0/INFO] [Plugin Loader] Loading plugin: generator-datapack-1.15.x from .\plugins\generator-datapack-1.15.x.zip
2020-04-27-20:43:54 [AWT-EventQueue-0/INFO] [Application] Loading generator: 1.12.2/generator.yaml
2020-04-27-20:43:54 [AWT-EventQueue-0/INFO] [Application] Loading generator: 1.14.4/generator.yaml
2020-04-27-20:43:54 [AWT-EventQueue-0/INFO] [Application] Loading generator: datapack-1.14.x/generator.yaml
2020-04-27-20:43:54 [AWT-EventQueue-0/INFO] [Application] Loading generator: datapack-1.15.x/generator.yaml
2020-04-27-20:43:56 [Thread-10/INFO] [Website API] Checking Pylo user session
2020-04-27-20:43:58 [Thread-12/INFO] [GA] Tracking page: /2020.2/launch
2020-04-27-20:44:00 [AWT-EventQueue-0/INFO] [Generator 1.14.4] Gradle cache will be loaded from cache file
2020-04-27-20:44:00 [AWT-EventQueue-0/INFO] [Workspace] Loaded workspace file C:\Users\9678Dash\MCreatorWorkspaces\dashboioverhaul\dashboioverhaul.mcreator
2020-04-27-20:44:00 [AWT-EventQueue-0/INFO] [MCreator] Opening MCreator workspace: dashboioverhaul
2020-04-27-20:44:10 [Thread-18/INFO] [GA] Tracking event: new_mod_element - Procedure
2020-04-27-20:45:00 [pool-3-thread-1/DEBUG] [Workspace File Manager/DASHBOIOVERHAUL] Workspace stored on the FS
 

Hopefully i can figure out a way to fix it, as not being able to use procedures is limiting.

The log shows no errors, are you sure the log is from the right time?

I would suggest trying to reinstall or run as admin too

It should be from the correct time. I'll try out those suggestions.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.