migration 1.12.2-1.14.4

Published by Darklaime on Thu, 05/07/2020 - 08:07
Status
Resolved
Type
Product/platform
MCreator/Windows
Priority
Normal
Issue description

I wanted to migrate to 1.14.4 but it went wrong, when I tried it and launched my game at 99% load of the home page it crashed without leaving any error message like (ametix tool, magicpowder) and the more I asked the discord of north west tree and nobody found the problem please help me

thank Darklaime

Issue comments

When possible, attach your MCreator workspace (or even better a minimal example workspace required to reproduce the bug), game logs (full logs, do not crop them, in text format, not screenshots of logs) from the Console tab or terminal and steps to reproduce the bug in your workspace. If logs are long, use service such as Pastebin to host the log and provide the link to the log from the ticket. Please specify which mod elements to check in your workspace too, if applicable.
 

Recreate mod element Goldenkey and give it a different name, it seems you use goldenkey registry name for something else too. Please do not change registry names without knowing what you are doing.

Then when I change the ID of the key, all the sword broke and when I put another boot (pickaxe, axle, shovel) it worked and when I put back in the sword its still not working, why I have lots of bugs like that ?

Avoid changing registry names, this is not recommended as registry names are used and referenced in many places



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.