i tried to make a mob but didn`t work

Published by elisei121 on Mon, 05/25/2020 - 14:11
Status
Invalid
Type
Product/platform
MCreator/Windows
MCreator version
Priority
Normal
Issue description

I tried to create a mob but it gives me an error.
I tried to change things there but it didn't work.
Can you help me please?

Attachment Size
Captură ecran (49).png131.04 KB 131.04 KB
l.png815.7 KB 815.7 KB
Captură ecran (50).png342.77 KB 342.77 KB

Issue comments

2020.4??

Also, this is caused by using 1.15.2 model in 1.14.4. Despite the fact you were warned about this when you imported your model.

in the console write:

Executing Gradle task: build
Build info: MCreator 2020.3.21322, forge-1.14.4, 64-bit, 8174 MB, Windows 10, JVM 1.8.0_252, JAVA_HOME: C:\Program Files\Pylo\MCreator\jdk
> Configure project :
New Dep: net.minecraftforge:forge:1.14.4-28.2.16_mapped_snapshot_20190719-1.14.3
> Task :compileJava UP-TO-DATE
> Task :processResources UP-TO-DATE
> Task :classes UP-TO-DATE
> Task :jar
> Task :downloadMcpConfig
> Task :extractSrg UP-TO-DATE
> Task :createMcpToSrg UP-TO-DATE
> Task :reobfJar
> Task :assemble
> Task :compileTestJava NO-SOURCE
> Task :processTestResources NO-SOURCE
> Task :testClasses UP-TO-DATE
> Task :test NO-SOURCE
> Task :check UP-TO-DATE
> Task :build
Deprecated Gradle features were used in this build, making it incompatible with Gradle 5.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/4.9/userguide/command_line_interface.html#sec:c…
BUILD SUCCESSFUL in 18s
7 actionable tasks: 3 executed, 4 up-to-date
Task completed in 18538 milliseconds

image: https://www.photojoiner.net/v/nVlBRYNJ

sorry but I didn't understand before because I'm Romanian and I use google translation to translate everything.
only now do I think I've figured out what to do.

you have the link here:
https://pastebin.com/SnhrDLUN

This is code of your model:

// Made with Blockbench 3.5.2
// Exported for Minecraft version 1.14
// Paste this class into your mod and generate all required imports

public static class Modelpink_slime extends EntityModel {

	public Modelpink_slime() {
		textureWidth = 64;
		textureHeight = 32;

	}

	@Override
	public void render(Entity entity, float f, float f1, float f2, float f3, float f4, float f5) {

	}

	public void setRotationAngle(ModelRenderer modelRenderer, float x, float y, float z) {
		modelRenderer.rotateAngleX = x;
		modelRenderer.rotateAngleY = y;
		modelRenderer.rotateAngleZ = z;
	}

	public void setRotationAngles(float f, float f1, float f2, float f3, float f4, float f5, Entity e) {
		super.setRotationAngles(f, f1, f2, f3, f4, f5, e);
	}
}

Your model is empty, it has no elements so naturally you will not see anything.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.