Custom mob model texture glitch

Published by MrNath on Tue, 05/26/2020 - 05:03
Status
Resolved
Type
Product/platform
MCreator/Windows
Priority
Normal
Issue description

I made a custom mob model in the Blockbench and after that i generated a texture map for it. I painted the model to get the colors and patterns i wanted and it looked perfect, but, when i lauch the game and spawn the entity, its texture is glitched. The texturemap is all over its body instead of each part being correctly where they are supposed to be. Any ideas what can that mean? I tried to see if i accidentally painted a pixel off the texture map but i'm sure i didn't. I generated another default texturemap for it and tested, the issue persists.

Attachment Size
Mob model on blockbench193.32 KB 193.32 KB
mob texturemap9.69 KB 9.69 KB
workspace171.17 KB 171.17 KB

Issue comments

To me it seems like you did not import the final texture but the template. Make sure you selected the right texture.

Yes, the screeshot is about that "test" i made with the template to see if the problem was my texture, but well the same thing happened so it wasn't

The scale of the texture is different of what i configured (128x128). The pixels are way smaller than in a normal texture, like an hd texture

 

Workspace attached. can you please check the modelcustom_model and the stone_golem.png?

Nope, nevermind. I recreated the model and it worked. A bit tiring but well, it worked. Thanks again for your patience!



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.