“Execute Command" block shows the command on the chat 1.12

Published by Lilmrmagoo on Wed, 02/12/2020 - 02:09
Upvotes: 1
Issue description

the command block shows the output in chat maybe it's because I'm using the execute command to find local entities nearby and summon near ontop of them. 1.12 btw.

 

Attachment Size
denkiBigShock.ptpl989 bytes 989 bytes
tester.zip5.69 MB 5.69 MB

Issue comments

I have tried to replicate this and was not able to. Please provide your workspace.

When possible, include your MCreator workspace (or even better a minimal example workspace required to reproduce the bug), game crash logs (full logs, do not crop them, in text format, not screenshots of logs) from the Console tab or terminal and steps to reproduce the bug in your workspace. Please specify which mod elements to check in your workspace too, if applicable.
 

Submitted by Lilmrmagoo on Wed, 02/12/2020 - 20:00

i added the procedure i belive it's becuase the command is /execute @e[rm=1,r=10] ~ ~ ~ /summon lightning_bolt

I have called all your procedure blocks and nothings was printed. Are you sure you use 20202.1? Maybe a screen recording of how does this look like as I can not reproduce this?

Please attach full workspace, if have command block output to true and this is not happening.

Submitted by Lilmrmagoo on Thu, 02/13/2020 - 21:25

added it sorry for my awful workspace it's just being used to make procedures and some testing

I see, you are using execute @e which will notify the nearest entity of the event. This is controlled by the execute command and not by code. You will need to rewrite your commands to not print out text, if this is possible or not, I am not sure.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.