[Spigot 1.16.5] Cannot find symbol

Started by jadenquinn8 on Sat, 03/27/2021 - 23:35

Topic category: Troubleshooting, bugs, and solutions

Last seen on 22:06, 24. May 2021
Joined Oct 2015
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
[Spigot 1.16.5] Cannot find symbol
Sat, 03/27/2021 - 23:35

I created a plugin with the spigot 1.16.5 plugin on the new MCreator snapshot and got this error. All I did was create a command and a procedure on top of that:

Executing
    Gradle task: build

Build
    info: MCreator 2021.1.12313 EAP (12313), spigot-1.16.5, 64-bit, 32699 MB,
    Windows 10, JVM 1.8.0_275, JAVA_HOME:
    C:\Users\jaden\Downloads\MCreatorEAP20211b12313\jdk

>
    Task :compileJava FAILED

C:\Users\jaden\MCreatorWorkspaces\jadensplug\src\main\java\to\us\iredmc\jadensplug\JadensplugMod.java:23:
    error: cannot find symbol
 
         getServer().getPluginManager().registerEvents(new
    JadenCommandExecutedProcedure(), this);

 
                                                           ^

 
     symbol:   class JadenCommandExecutedProcedure

 
     location: class JadensplugMod

1
    error

FAILURE:
    Build failed with an exception.

*
    What went wrong:

Execution
    failed for task ':compileJava'.

>
    Compilation failed; see the compiler error output for details.

*
    Try:

Run
    with --stacktrace option to get the stack trace. Run with --info or
    --debug option to get more log output. Run with --scan to get full
    insights.

*
    Get more help at https://help.gradle.org

BUILD
    FAILED in 203ms

1
    actionable task: 1 executed

BUILD
    FAILED

Task
    completed in 3 seconds

BUILD
    FAILED

Task
    completed in 3 seconds

Last seen on 22:06, 24. May 2021
Joined Oct 2015
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I noticed a small error at…
Sat, 03/27/2021 - 23:40

I noticed a small error at the bottom when I tried to delete this and try again, and it says "The selected generator doesn't support this block. It will be skipped" - But the problem is that the plugin will be completely useless if it can't modify the world or entities so is this plugin completely useless?

Last seen on 22:06, 24. May 2021
Joined Oct 2015
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Update: It still won't let…
Sat, 03/27/2021 - 23:43

Update: It still won't let me build even though there was no error at the bottom this time, just can't build: https://pastebin.com/q3Lj9ZK8

I suggest you open a bug…
Sun, 03/28/2021 - 11:36

I suggest you open a bug report on the issue tracker of spigot plugin

Last seen on 14:47, 13. Jun 2021
Joined Aug 2016
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I just need to update the…
Sat, 04/03/2021 - 13:13

I just need to update the command mod element to support the new feature of the commands.