Please add .json model support

Started by Jamesb013 on Wed, 02/08/2017 - 00:52

Topic category: Feature requests and ideas for MCreator

Last seen on 23:40, 10. Aug 2019
Joined Dec 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Please add .json model support
Sat, 04/01/2017 - 09:26 (edited)

Please add .json model support to the new Mcreator updates/ possibly for some of the older mcreator downloads as well so many people would love this addition! Techne is a good program but I prefer to use cubik myself.

Edited by Klemen on Sat, 04/01/2017 - 09:26
Last seen on 14:35, 27. Jun 2019
Joined Dec 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
i use .jason files for all of
Wed, 02/08/2017 - 02:34

i use .jason files for all of my models it is supported

Last seen on 18:52, 24. Aug 2018
Joined Dec 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
There is .obj and .json
Wed, 02/08/2017 - 18:04

There is .obj and .json support for blocks and items.

Last seen on 23:40, 10. Aug 2019
Joined Dec 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
RE:There is .obj and .json
Mon, 03/27/2017 - 23:47

@#2  I have tried to use .json models but its not working with my Mcreator could you take a screenshot of where it is and post it maybe? maybe im looking in the wrong place.

 

Last seen on 13:00, 15. Aug 2018
Joined Apr 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Json
Tue, 03/28/2017 - 16:21

What do you mean exactly that it doesn't work? The location to select json models is on the 1st page of creating a block > block model custom > json model and then import your json model. If the block is white and purple squares you probably made the model bigger than a normal minecraft block.

Last seen on 23:40, 10. Aug 2019
Joined Dec 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
RE:Json
Tue, 03/28/2017 - 17:07

@#3 Well when I select custom in the drop down box in render type I can only use .java models and I see no option for .json models anywhere.

Last seen on 13:00, 15. Aug 2018
Joined Apr 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Json
Tue, 03/28/2017 - 17:16

.java models are really old, what version are you using?

Last seen on 23:40, 10. Aug 2019
Joined Dec 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
RE:Json
Tue, 03/28/2017 - 17:18

@#4 1.7.2 for 1.7.10

Last seen on 13:00, 15. Aug 2018
Joined Apr 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Json
Tue, 03/28/2017 - 17:20

I guess .json isn't supported in that version, I only used for 1.8+ and those have json models. I guess i can't help then sorry :/

Last seen on 23:40, 10. Aug 2019
Joined Dec 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
RE:Json
Tue, 03/28/2017 - 17:21

@#5 (insert tear face here) .... all hope is lost lol please is anyone has a work around do share!

Last seen on 22:34, 29. Apr 2019
Joined Mar 2017
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
I agree Jamesb013! I use 1.8
Fri, 03/31/2017 - 22:24

I agree Jamesb013! I use 1.8 too, but I also use that version of 1.7.10. Hope hop they can update it some day. Also, when I do choose a .java for that version, it doesn't work for some reason? It tells me to select one before moving on, even thouhg I already selected it.