MCreator crashes when export mods.

Published by Matrillex on Sun, 09/09/2018 - 23:57
Upvotes: 1
Issue description

I've been using MCreator 1.6.4 for 1.8 mods and every time I make any mod of any kind it crashes when I try to export. It doesn't say or do anything, it just crashes. I've been looking around the internet and have found other posts on it but nothing has really helped me fix it myself. It use to work awhile ago so I don't know why it is no longer working. I've tried uninstalling and reinstalling several times and have tried the Installer and Archive download. I have also tried both opening as and not opening as Administrator. I have also tried making a basic mod that only has the parts filled out needed to press the next button but MCreator still crashes.

Issue comments

Submitted by Matrillex on Mon, 09/10/2018 - 16:48

I also tried this for 1.6.4
 

Try to open file user/preferences.conf inside MCreator's installation directory and add new line ui=legacy

Try to import the texture after you do this and it should fix the bug. Please report back if this worked so we can provide an official fix. Thanks!

As suggested in the other page and preferences.conf was blank when I opened it (opened with notepad) I put ui=legacy in anyways and it had no effect.

Submitted by Matrillex on Thu, 09/13/2018 - 02:53

Also I don't know if "crashing" is quite the right word; it might be closer to just closing since I'm not noticing a crash report, unless you have to look else where for that. 

I am not aware of any other fixes than these provided in original ticket unfortunately. You might want to use newer versions of MCreator that have this bug fixed in code.

Submitted by Matrillex on Thu, 09/13/2018 - 14:43

Are there any other versions that make mods for 1.8?

And is there anyway you or someone else could upload a version with the ui=legacy fix to google docs or Dropbox? I'm not sure why it doesn't seem to work for me but it might work for someone else.

No, 1.8 is outdated and we dropped the support for 1.8 versions of MCreator.

Submitted by Matrillex on Thu, 09/13/2018 - 16:02

That is unfortunate since both I and my friends use 1.8

Submitted by Matrillex on Thu, 09/13/2018 - 16:04

If I figure anything out myself I'll post it here.

Submitted by Oath on Mon, 05/06/2019 - 14:40

you can always re create those mods