When I try to import texture, MCreator crashes

Submitted by ChippoMax on Fri, 02/09/2018 - 22:24
Issue description

I have recently been having a problem with MCreator and wondered what was happening.

What happens is when I create a new mob and go to import a new texture from my computer, the whole program ends up crashing.

Video of the crash: https://www.youtube.com/watch?v=2OXENGgvHBs

Error log: https://drive.google.com/file/d/1uVHcEH-r4JSndA-S_1jOC5TVpeMpvhQP/view

System:

  • CPU - AMD FX-8350
  • RAM - 16 GB
  • GPU - GTX 970
  • OS - Windows 10 Home (64 bit), version 1709

DEVELOPERS EDIT:

There will be an official fix for this bug in MCreator 1.7.8. Workarounds can be found in the comments of this issue.

Issue comments

Submitted by Klemen on Sun, 02/11/2018 - 10:10

Try to open file user/preferences.conf inside MCreator's installation directory and add new line ui=legacy

Try to import the texture after you do this and it should fix the bug. Please report back if this worked so we can provide an official fix. Thanks!

More details about this bug which is actually a Java bug: https://bugs.openjdk.java.net/browse/JDK-8178873

Submitted by Klemen on Sun, 02/11/2018 - 10:15

I can confirm this can be fixed using legacy UI. This is a known Java bug. One can reproduce this in many ways, one of them is by creating a "God Mode" shortcut on the desktop. Create a folder called DevLinks.{ED7BA470-8E54-465E-825C-99712043E01C} on the Desktop and it will cause MCreator and any other Java app with Windows UI to crash.

We have found a fix for this and it will be fixed in 1.7.8 and most likely backported to older versions in the future. For now, one can fix this by setting the ui to legacy mode as instructed in the previous comment.

Submitted by ChippoMax on Sun, 02/11/2018 - 10:35

Thanks for getting back,

I changed the UI to legacy and it now works, thanks for providing all of the details. I do actually have a god mode folder on my desktop with a similar name (GodMode.{ED7BA470-8E54-465E-825C-99712043E01C}). Was this folder the reason?

Thanks again!

Same problem! I don't really understand the answer, if you could please rewrite it in a more detailed way, that would help, i'll try this anyway even though I don't understand it, thanks!