MCreator workspace import stuck on Loading mods

Submitted by KreatorB on Sat, 09/01/2018 - 04:14
Upvotes: 0
Issue description

I just installed version 1.8.0 and migrated my files over from 1.7.9, tested and even added some elements to the mod. I then did an uninstall ov version 1.7.9 which was in a different folder. And now I can no longer start the MCreator v1.8.0.... I is always stuck on the loading workspace data.. Please hELP!!!!

 

Issue comments

Submitted by Super_m on Tue, 09/04/2018 - 02:22

I finally found out the problem. I launched minecraft test environment, it wokled fine. I exited the game, then closed MCreator, but now that I try to turn MCreator back on it doesn't work anymore. There's something wrong with the test environment.

Submitted by sssssh on Tue, 09/04/2018 - 22:16

Here is the full thing, Klemen.

[Wed Sep 05 08:14:30 AEST 2018] [Launcher] Java version: 1.8.0_172, specification: 1.8
[Wed Sep 05 08:14:30 AEST 2018] [Launcher] Installation path: C:\Pylo\MCreator180
[Wed Sep 05 08:14:30 AEST 2018] [Launcher] User home of MCreator: C:\Users\Ash\.mcreator\
[Wed Sep 05 08:14:30 AEST 2018] [WebIO] Reading from URL: https://mcreator.net/app
[Wed Sep 05 08:14:35 AEST 2018] java.net.SocketTimeoutException: connect timed out
[Wed Sep 05 08:14:35 AEST 2018]         at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method)
[Wed Sep 05 08:14:35 AEST 2018]         at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:85)
[Wed Sep 05 08:14:35 AEST 2018]         at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)
[Wed Sep 05 08:14:35 AEST 2018]         at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
[Wed Sep 05 08:14:35 AEST 2018]         at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
[Wed Sep 05 08:14:35 AEST 2018]         at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172)
[Wed Sep 05 08:14:35 AEST 2018]         at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
[Wed Sep 05 08:14:35 AEST 2018]         at java.net.Socket.connect(Socket.java:589)
[Wed Sep 05 08:14:35 AEST 2018]         at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:673)
[Wed Sep 05 08:14:35 AEST 2018]         at sun.net.NetworkClient.doConnect(NetworkClient.java:175)
[Wed Sep 05 08:14:35 AEST 2018]         at sun.net.www.http.HttpClient.openServer(HttpClient.java:463)
[Wed Sep 05 08:14:35 AEST 2018]         at sun.net.www.http.HttpClient.openServer(HttpClient.java:558)
[Wed Sep 05 08:14:35 AEST 2018]         at sun.net.www.protocol.https.HttpsClient.<init&gt;(HttpsClient.java:264)
[Wed Sep 05 08:14:35 AEST 2018]         at sun.net.www.protocol.https.HttpsClient.New(HttpsClient.java:367)
[Wed Sep 05 08:14:35 AEST 2018]         at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.getNewHttpClient(…
[Wed Sep 05 08:14:35 AEST 2018]         at sun.net.www.protocol.http.HttpURLConnection.plainConnect0(HttpURLConnection.jav…
[Wed Sep 05 08:14:35 AEST 2018]         at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java…
[Wed Sep 05 08:14:35 AEST 2018]         at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractD…
[Wed Sep 05 08:14:35 AEST 2018]         at sun.net.www.protocol.https.HttpsURLConnectionImpl.connect(HttpsURLConnectionImp…
[Wed Sep 05 08:14:35 AEST 2018]         at co.pylo.mcreator.j.a.a(Unknown Source)
[Wed Sep 05 08:14:35 AEST 2018]         at co.pylo.mcreator.j.b.a.a(Unknown Source)
[Wed Sep 05 08:14:35 AEST 2018]         at co.pylo.mcreator.a.<init>(Unknown Source)
[Wed Sep 05 08:14:35 AEST 2018]         at co.pylo.mcreator.Launcher.lambda$main$1(Unknown Source)
[Wed Sep 05 08:14:35 AEST 2018]         at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
[Wed Sep 05 08:14:35 AEST 2018]         at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
[Wed Sep 05 08:14:35 AEST 2018]         at java.awt.EventQueue.access$500(EventQueue.java:97)
[Wed Sep 05 08:14:35 AEST 2018]         at java.awt.EventQueue$3.run(EventQueue.java:709)
[Wed Sep 05 08:14:35 AEST 2018]         at java.awt.EventQueue$3.run(EventQueue.java:703)
[Wed Sep 05 08:14:35 AEST 2018]         at java.security.AccessController.doPrivileged(Native Method)
[Wed Sep 05 08:14:35 AEST 2018]         at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
[Wed Sep 05 08:14:35 AEST 2018]         at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
[Wed Sep 05 08:14:35 AEST 2018]         at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205)
[Wed Sep 05 08:14:35 AEST 2018]         at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
[Wed Sep 05 08:14:35 AEST 2018]         at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
[Wed Sep 05 08:14:35 AEST 2018]         at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
[Wed Sep 05 08:14:35 AEST 2018]         at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
[Wed Sep 05 08:14:35 AEST 2018]         at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
[Wed Sep 05 08:14:37 AEST 2018] Pylo sync status: false
[Wed Sep 05 08:14:37 AEST 2018] [GA] Tracking page: /1.8.0/launch
[Wed Sep 05 08:14:45 AEST 2018] Failed to open data for: LithiumPowder
[Wed Sep 05 08:14:45 AEST 2018] Failed to open data for: Tab
[Wed Sep 05 08:14:45 AEST 2018] Failed to open data for: LithiumIngot
[Wed Sep 05 08:14:45 AEST 2018] Failed to open data for: LithiumBlock
[Wed Sep 05 08:14:45 AEST 2018] Failed to open data for: LithiumOre
[Wed Sep 05 08:14:45 AEST 2018] Failed to open data for: Battery
[Wed Sep 05 08:14:45 AEST 2018] Failed to open data for: Jetpack
[Wed Sep 05 08:14:45 AEST 2018] [LegacyWorkspaceUtils] Loaded elements with raw IDs. Detecting mappings ...
[Wed Sep 05 08:14:45 AEST 2018] [LegacyWorkspaceUtils] Found mappings
[Wed Sep 05 08:14:45 AEST 2018] [LegacyWorkspaceUtils] Map for BLOCK: [0, 0, 0, 0, 0]
[Wed Sep 05 08:14:45 AEST 2018] [LegacyWorkspaceUtils] Map for ENTITY: [0, 0, 0, 0, 0]
[Wed Sep 05 08:14:45 AEST 2018] [LegacyWorkspaceUtils] Map for DIMENSION: [0, 0, 0, 0, 0]
[Wed Sep 05 08:14:45 AEST 2018] [LegacyWorkspaceUtils] Map for ITEM: [0, 0, 0, 0, 0]
[Wed Sep 05 08:14:45 AEST 2018] [LegacyWorkspaceUtils] Map for ACHIEVEMENT: [0, 0, 0, 0, 0]
[Wed Sep 05 08:14:45 AEST 2018] [LegacyWorkspaceUtils] Map for BIOME: [0, 0, 0, 0, 0]
[Wed Sep 05 08:14:45 AEST 2018] [LegacyWorkspaceUtils] Map for GUI: [0, 0, 0, 0, 0]
[Wed Sep 05 08:14:45 AEST 2018] [LegacyWorkspaceUtils] Applying mappings
[Wed Sep 05 08:14:45 AEST 2018] [LegacyWorkspaceUtils] Mappings applied
[Wed Sep 05 08:14:45 AEST 2018] [Workspace] Mods to load: 7
[Wed Sep 05 08:14:45 AEST 2018] [Workspace] Importing workspace of the same MCreator version, skipping conversion
[Wed Sep 05 08:14:45 AEST 2018] [CodeCorrectionUtils] Code correction disabled
[Wed Sep 05 08:14:45 AEST 2018] Failed to open data for: LithiumPowder
[Wed Sep 05 08:14:45 AEST 2018] Exception in thread "Thread-10" [Wed Sep 05 08:14:45 AEST 2018] java.lang.NullPointerException
[Wed Sep 05 08:14:45 AEST 2018]         at co.pylo.mcreator.modgui.m.a(Unknown Source)
[Wed Sep 05 08:14:45 AEST 2018]         at co.pylo.mcreator.workspace.e.b(Unknown Source)
[Wed Sep 05 08:14:45 AEST 2018]         at java.lang.Thread.run(Thread.java:748)
[Wed Sep 05 08:15:06 AEST 2018] [Workspace File System] - Storing workspace to the file system
 

Submitted by Klemen on Wed, 09/05/2018 - 06:46

Thank you for all the info. I will be busy for a few days but then I will do my best to find the cause and the fix to these bugs.

Submitted by sssssh on Wed, 09/05/2018 - 22:15

Cool, thanks!

- Sssssh

 

Submitted by Klemen on Sat, 09/08/2018 - 09:36

Super_m, is there any option that you could zip me the whole installation folder that is failing with this error without the jdk folder and upload it somewhere. This way I can get the exact same setup and debug the cause for this bug with MCreator being stuck on Loading workspace data. Thanks!

Submitted by Klemen on Sun, 09/09/2018 - 11:20

Thanks, this will help me a lot!

Submitted by Klemen on Sun, 09/09/2018 - 16:38

Further conversation about the issue about MCreator stuck at Loading workspace data was moved to another ticket as this ticket is about MCreator being stuck at Loading mods screen when importing the workspace.

Moved ticket: https://mcreator.net/tracker/issue/44383

Submitted by Klemen on Sat, 10/06/2018 - 16:39

I have managed to find the cause for this bug. The actual bug is with exporting mods that can cause corrupted exported mcr files that can't be imported properly.

In 1.8.1, the export will be fixed, I have also added support for importing corrupted workspaces, where MCreator skips all elements that are corrupted.

Submitted by guigs77 on Wed, 10/17/2018 - 13:14

for me the workspace was created but he doesnot want load