Elements refuse to compile after installation of version 2023.3

Started by MortiusTitanOfDeath on

Topic category: Troubleshooting, bugs, and solutions

Last seen on 22:26, 24. Jul 2024
Joined Apr 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
Elements refuse to compile after installation of version 2023.3
Sun, 09/03/2023 - 16:34 (edited)

As the title suggests, elements in my workspace refuse to compile and show an error. I also feel it's important to say that my caches got corrupted beforehand and all of that was weirdly triggered by the installation of the newer version of Mcreator (2023.3). I did change some things in the elements to possibly fix it, I did delete and recreate the elements, but it also did nothing. (Also, I did allow Mcreator on my antivirus, but it didn't change anything. I also restarted my computer multiple times.)

Here is the pastebin of the console :

https://pastebin.pl/view/6e84b3ce

(I also deleted all the plugins in the folder)

Edited by MortiusTitanOfDeath on Sun, 09/03/2023 - 16:34
Last seen on 22:26, 24. Jul 2024
Joined Apr 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
I just found out that it…
Sun, 09/03/2023 - 18:17

I just found out that it does that for every workspace made before the update.

Last seen on 00:42, 10. Oct 2023
Joined Mar 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
Does regenerating the code…
Sun, 09/03/2023 - 21:24

Does regenerating the code help?

Last seen on 03:19, 17. Feb 2024
Joined May 2015
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
I'm not sure if this is the…
Sun, 09/03/2023 - 22:04

I'm not sure if this is the problem you are facing, but for some reason MCreator has a chance to not work on certain versions of display drivers. I don't know why that happens, but this could be a good avenue for investigation. Hope this helps.

Last seen on 22:26, 24. Jul 2024
Joined Apr 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
Replying to McModded1.14, no…
Sun, 09/03/2023 - 23:01

Replying to McModded1.14, no, unfortunately, it doesn't help

Last seen on 22:26, 24. Jul 2024
Joined Apr 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
Replying to JAK_the_Cyborg,…
Sun, 09/03/2023 - 23:02

Replying to JAK_the_Cyborg, thank you for your reply, I will check this out. 

This seems like broken…
Mon, 09/04/2023 - 15:19

This seems like broken caches.

The solution to this problem and many other problems can be found in our knowledge base: https://mcreator.net/support/knowledgebase Please check the knowledge base before opening a new topic on the issue which has a known fix.

Last seen on 22:26, 24. Jul 2024
Joined Apr 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
I did what it says, but it…
Mon, 09/04/2023 - 16:12

I did what it says, but it doesn't seem to fix the issue.

Last seen on 22:26, 24. Jul 2024
Joined Apr 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
It seems like I am far from…
Wed, 09/06/2023 - 23:05

It seems like I am far from the only one having this issue. Perhaps something is wrong in the new version, since older ones worked just fine.