My Mod wont work when I play it with the Original Minecraft

Started by Hygerian on

Topic category: Troubleshooting, bugs, and solutions

Last seen on 19:35, 23. Feb 2024
Joined Feb 2022
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
My Mod wont work when I play it with the Original Minecraft

Hello, I need help!
I am currently making a huge mod that adds Blocks, Items, Mobs, Biomes, 1 Dimension and more
and I am using the Geckolib Plugin for some of my Mobs so they look better.
I also use the right version for the Geckolib Plugin.
So when I play the mod in Mcreator everything is fine and works but when i export it and try to play it as soon as the loading screen of Minecraft stopped loading there is a error message that says: "(ModName) has failed to load correctly | java.lang.NoClassDefFoundError: software/bernie/geckolib/animatable/GeoEntity" and I cant play it in the Original Minecraft.
It would be really nice if someone of you guys could help me with this problem, because this error destroys a mod that has over 400 mod elements!

Last seen on 15:47, 20. Feb 2024
Joined May 2023
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
it might be because you don…
Sun, 10/15/2023 - 21:29

it might be because you don't have geckolib installed

Last seen on 19:35, 23. Feb 2024
Joined Feb 2022
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
No thats not the case, but…
Mon, 10/16/2023 - 15:52

No thats not the case, but thanks for helping!