Geckolib Animated Entities Glitch

Started by NathVer1 on

Topic category: Help with modding (Java Edition)

Last seen on 17:53, 18. Feb 2024
Joined Oct 2023

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
Geckolib Animated Entities Glitch
Wed, 10/25/2023 - 06:33 (edited)


I am encountering this issue with Geckolib animated entities:

I have also tried it on different versions of MCreator and Minecraft, specifically: 

  • [Geckolib 4.8.7] - MCR 2023.2 - 1.19.2 
  • [Geckolib 4.8.8] - MCR 2023.3 EAP 34614 - 1.20.1 (the test shown in the video above)  
  • [Geckolib 4.8.8] - MCR 2023.3 - 1.20.1 and 1.19.2 (plugin) 

Every time with a fresh install of MCreator (cache deleted as well), and a new project.
Mobs have no procedures; I also tried disabling AI without getting results. Furthermore, in version 1.19.2, the bug appears more ambiguously, almost the opposite:
while in 1.20.1, the bug is temporarily resolved by exiting and re-entering the world, in 1.19.2, this issue mainly (but not exclusively) occurs after re-entering the world.

I couldn't find anything useful online; can anyone help me please?

EDIT: It seems like the issue only occurs in the editor; the exported file doesn't seem to have any problems (Tested with MCR 2023.2 - 1.19.2 )

Edited by NathVer1 on Wed, 10/25/2023 - 06:33