Workspace Setup - Timeout Error

Started by Reza on

Topic category: Help with MCreator software

Last seen on 14:08, 29. Nov 2023
Joined Nov 2023

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
Workspace Setup - Timeout Error

I'm sorry for posting yet another setup fail post but honestly I think I've tried every possible way to fix it before, at last, posting for help here. I'm new to MCreator, never used it before. First install and I'm getting this error, it's really frustrating. I tried the latest stable version (2023.3) and even the snapshot (2023.4), but to no avail. I even asked ChatGPT for help (lmao) and followed its steps but still nothing. Here's a few more things I tried
- Deleting gradle folder from the ~/.mcreator folder
- Deleting gradle folder from the mod's workspace folder
- Allowing the folders through Windows Defender to prevent any blockages
- Checked the link of the gradle download myself (and yes it does start)
- Reinstalled MCreator
- Downloaded the Gradle thing myself, put its zip's contents in the dist/gradle.x.x's bin folder
- Tried other generators

But yes, nothing works.

Here's a link to the log: