Dimension Dense Fog Not Working with Latest MCreator

Started by Cram9io on

Topic category: Troubleshooting, bugs, and solutions

Last seen on 22:08, 21. Feb 2024
Joined Sep 2023
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
Dimension Dense Fog Not Working with Latest MCreator
Thu, 02/08/2024 - 19:22 (edited)

I have a mod that adds a dimension with dense fog enabled. When I start the dev Minecraft through Mcreator, the fog works just fine. But when I export the file and run it standalone, the fog is no longer there. Is there something that I'm doing wrong, because this is only in the latest version of my mod, while the previous ones work just fine.

 

 

Bottom: Normal

Top: No fog (issue)

 

Edit: (I remade the dimension and now its done the next best thing - just not be foggy whatsoever - even during MCreator testing that it worked in before)

 

https://imgur.com/a/kYD5LtH - here is my current settings for the dimension if it helps!

 

Update: So here is the full issue after investigating it:

  • A dimension in my mod, although having the "enable dense fog" option checked, is not showing the dense fog.
  • Another dimension in my mod, which has the same settings, does have dense fog working.
  • I have tried regenerating code and remaking the dimension, all to no avail.
  • I have come to suspect that this is a potential bug with MCreator. Please tell me otherwise if I am wrong, however. I attached an image of my settings so you can see if I have done anything wrong.
Edited by Cram9io on Thu, 02/08/2024 - 19:22