Repeated Errors and Deletion of Workspaces

Started by RamenNoods on

Topic category: Troubleshooting, bugs, and solutions

Last seen on 20:43, 17. Apr 2024
Joined Feb 2024
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
Repeated Errors and Deletion of Workspaces

This has happened to me multiple times, specifically after my wifi gets turned off in the middle of a build.

Several mod elements are marked as errors, usually "cant find symbol" errors.
All it takes to fix these errors is to go through all of the properties of the element and retype them, then save them.

This worked the first time this happened to me, but it happened again and now, whenever I try that, it just creates more errors on different elements.

Regenerating/clearing cache, restarting Mcreator, restarting PC does not do anything.
In fact, when I tried regenerating code this time, my whole workspace was deleted. (Luckily i had a recent zip of the workspace to replace it)

I still have the errors though. If I can't get help on this forum page, ill put the zip on the git issue tracker.