Process 'Gradle Worker Daemon 1' finished with non-zero value 1

Started by B08sokisc on

Topic category: Help with modding (Java Edition)

Last seen on 12:47, 12. Jun 2024
Joined Mar 2024

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
Process 'Gradle Worker Daemon 1' finished with non-zero value 1

When I try to make (or open) a fabric based project, I always get this error:

Error: Could not find or load main class
Caused by: java.lang.ClassNotFoundExeption:
FALIURE: Build failed with an exeption.
* What went wrong:
Execution failed for task  ' :genSourcesWithCfr '.
> There was a faliure while executing work items.
    >A failure occured while executing net.fabricmc.loom.task.GenerateSourcesTask$DecompileAction
        > Failed to run Gradle Worker Daemon
            > Process  'Gradle Worker Daemon 1'  finished with non-zero exit value 1

I have tried all the basic solutions, none worked: letting MCreator through firewall, deleting gradle files, deleting gradle cache, reinstalling MCreator, reinstalling MCreator to a different place, updating Java, restarting my PC, giving more RAM to gradle, running it as an administrator.

On the other hand, forge works absolutely fine. Gradle works there, but not in fabric

Seems like bug of fabric…
Mon, 03/25/2024 - 18:04

Seems like bug of fabric plugin or fabric, so I would recommend getting in touch with MCreator plugin author