Generating World hangs at 0%

Started by 2TheEdge on

Topic category: Troubleshooting, bugs, and solutions

Last seen on 19:18, 19. Apr 2024
Joined Apr 2024
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
Generating World hangs at 0%

I have a mod that contains a lot of different structures and features that generate in the world, and it has worked well up until recently. However, upon updating to MCreator 2024.1, I can no longer generate new worlds as the game will always hang (not crash) at 0% on the generating world screen. Worlds I generated before updating can still be loaded and they work just fine, so I figure it has to be something regarding how world gen has changed in 2024.1. I was wondering if anyone knew what changes MCreator made to world gen in 2024.1 that could have caused my mod to stop generating worlds.

I can provide more details regarding how these structures/features spawn if you need them!

Last seen on 20:52, 22. Jun 2024
Joined Oct 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
This is happening to me too,…
Tue, 05/14/2024 - 01:28

This is happening to me too, it went to 1% after like an hour though. I've added a few structures, features, and biomes recently, that could be why

Last seen on 20:52, 22. Jun 2024
Joined Oct 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
nvm I just had to update…
Tue, 05/14/2024 - 02:48

nvm I just had to update MCreator

have a mod that contains a…
Tue, 05/14/2024 - 14:33

have a mod that contains a lot of different structures and features that generate in the world, and it has worked well up until recently. However, upon updating to MCreator 2024.1, I can no longer generate new worlds as the game will always hang (not crash) at 0% on the generating world screen. Worlds I generated before updating can still be loaded and they work just fine, so I figure it has to be something regarding how world gen has changed in 2024.1. I was wondering if anyone knew what changes MCreator made to world gen in 2024.1 that could have caused my mod to stop generating worlds.

I recommend re-downloading and re-installing MCreator as latest 2024.1 patch update fixes this