MCreator won't start.

Started by TheSnarkyKnight on Sun, 01/24/2016 - 10:49
Last seen on 19:49, 24. Jan 2016
Joined Jan 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
MCreator won't start.
Sun, 01/24/2016 - 10:49

I have encountered a problem with MCreator 1.4.8: it doesen't connect to the Pylo servers.

I have already tried to uninstall it and re-install it with my antivirus turned off. but it didn't work. It's weird because I have installed the most recent version and it worked perfectly.

Anyway, i added pause to the START.bat and got this error out of it:

Exception in thread "main" java.lang.NumberFormatException :

For input string:"<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 20//EN">

<html><head><title>301 Moved Permanently</title></head><body><h1>Moveed Permanently</h1><p>The document has moved <a href="https://wwwpyloco/mcreator/app/editiontxt">here</a></p></body></html>"

at java.lang.NumberFormatException.forInputString<UnknownSource>

at java.lang.Integer.parseInt<Unknown Source>

at java.lang.Integer.parseInt<Unknown Source>

at si.pylo.mcreator.MainUi.<init><MainUi.java:510>

at si.pylo.mcreator.MainUi.main<MainUi.java:2857>

 

My java specs:

Java version "1.7.0_72"

Java SE Runtime Environment <build 1.7.0_72-b14

Java HotSpot 64-Bit Server VM <build 24.72-b04, mixed mode>

 

I think that MCreator is trying to get the libraries at an old html.Soooo, how do i fix this?

Last seen on 19:49, 24. Jan 2016
Joined Jan 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Doesen't anyone know the
Sun, 01/24/2016 - 18:34

Doesen't anyone know the anything?

 

Last seen on 19:03, 14. Mar 2016
Joined Nov 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Hi Everyone
Sun, 01/24/2016 - 19:00

Hi Everyone

Yes... Older versions of MCreator below 1.7.10 won't connect to Pylo Servers, because they are no longer supported, i.e. MCreator will only run the servers for the latest and most popular game versions such as 1.7.10, 1.8, etc.

I personally found this frustrating for MCreator 1.7.2

Last seen on 19:49, 24. Jan 2016
Joined Jan 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Well bugger.
Sun, 01/24/2016 - 19:10

Well bugger.

My sister has an old computer that cannot run 1.7.10 so I'm forced to work on 1.6.4.

Any way to easily backport from 1.7.10 to 1.6.4?

Last seen on 19:03, 14. Mar 2016
Joined Nov 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Hi TheSnarkyKnight
Sun, 01/24/2016 - 19:40

Hi TheSnarkyKnight

What type of computer is it? I might be able to help you, I have had experience with computers as far back as 2002 using XP :-)

Also no its not easy, your probably better looking for a different mod maker application (which there isn't)

Last seen on 19:49, 24. Jan 2016
Joined Jan 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
HP550
Sun, 01/24/2016 - 19:49

HP550

Windows Vista

2 G Ram (it's laggy as f**k)

Java 7 installed

I remember playing once in 1.7.10 on that computer, but I can't seem to make that work now.

Last seen on 19:03, 14. Mar 2016
Joined Nov 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Hi TheSnarkyKnight
Sun, 01/24/2016 - 20:15

Hi TheSnarkyKnight

Im using Windows Vista right now, so this should be really easy to solve :-)

I Currenlty play Minecraft 1.7.2 and I also used to play in 1.7.10, but you cant run 1.7.10 with forge with Java 7... I make mods using MCreator 1.7.10 and the mods are also compatiable with Minecraft 1.7.2... 

To solve your problem, uninstall what ever version of forge you have, and download the latest (Not recommended) forge 1.7.2... It has to be the latest. Then run minecraft with the new forge.

Download MCreator 1.7.10 and run it...

Here is the catch... Because you are using MCreator 1.7.10 and you are playing Minecraft 1.7.2, some things in your mods may not work, e.g. if you create a block with sounds, the sounds may not play in 1.7.2... My advise is to make mods that are mostly new blocks and/or Items

I hope this helped you :-)