Newest 1.7.10 not downloading

Started by 12shadowlord21 on Fri, 06/24/2016 - 00:56

Topic category: Help with MCreator software

Last seen on 21:20, 6. Dec 2018
Joined Aug 2015
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Newest 1.7.10 not downloading
Fri, 06/24/2016 - 00:56

I, like so many other modded minecraft players, use 1.7.10 Forge because it has many mods that went extinct before 1.8 and up but also aren't too old. I have tried every download avalible on the website to get 1.6.3 Mcreator for 1.7.10, but it won't work. Every time I try, the link sends me to Adfly, where I wait 5 seconds and click the "Skip ad" button in the top right-hand corner of the screen. As soon as I click it, the tab closes and a new window opens with a random ad ranging from Norton Security to Roblox. I have tried waiting on the new page, I have tried checking my downloads, I have even not pressed the "Skip Ad" button and just waited. Is this just me, or is there a problem with both the Archive Zip folder and the other download for both 32 and 64 bit for Windows?

Last seen on 17:47, 12. May 2018
Joined Mar 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
did you used US download or
Fri, 06/24/2016 - 07:15

did you used US download or EU download?

Last seen on 21:20, 6. Dec 2018
Joined Aug 2015
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
RE:did you used US download or
Fri, 06/24/2016 - 13:45

@#1 ​I used the US download.

Last seen on 23:44, 18. Aug 2019
Joined Apr 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I had the EXACT SAME PROBLEM
Sat, 06/25/2016 - 13:30

I had the EXACT SAME PROBLEM when I tried to get MCreator. Weirdly enough, the 64-bit windows link strarted working when I downloaded from a different location. Try this link

http://www.mediafire.com/download/te00w9ggmy9eo31/MCreator+1.6.3+%5B1.7…

It is a direct link to the actual download, and should work for you.

Last seen on 17:47, 12. May 2018
Joined Mar 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
RE:RE:did you used US download or
Sat, 06/25/2016 - 13:49

@#1.1 try using EU one then

Last seen on 21:20, 6. Dec 2018
Joined Aug 2015
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
RE:I had the EXACT SAME PROBLEM
Sun, 06/26/2016 - 01:58

@#2 Thank you SO MUCH! I love making mods, but things like Techne wont work on the version I was using. Thank you!