Daemon Failed (can't recompile)

Started by Agent042s on Tue, 04/25/2017 - 10:53

Topic category: Bugs and solutions

Last seen on 12:16, 6. May 2017
Joined Apr 2017
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Daemon Failed (can't recompile)
Tue, 04/25/2017 - 10:53

It can't recompile. I don't know, wht to do. MCreator doesn't make anything without it.

[spoiler=Here is what it shows to me in console]Executing gradle command: build Microsoft Windows [Verze 6.1.7601]  Copyright (c) 2009 Microsoft Corporation. All rights reserved
C:\Pylo\MCreator172>cd forge
C:\Pylo\MCreator172\forge>SET "JAVA_HOME=C:\Pylo\MCreator172\jdk64\"
C:\Pylo\MCreator172\forge>SET JAVA_EXE=%JAVA_HOME%\bin\java.exe
C:\Pylo\MCreator172\forge>SET PATH=%JAVA_HOME%\bin\;%PATH%
C:\Pylo\MCreator172\forge>gradlew -Dorg.gradle.jvmargs="-Xms625m -Xmx2048m" build
o honour the JVM settings for this build a new JVM will be forked. Please consider using the daemon: http://gradle.org/docs/2.0/userguide/gradle_daemon.html.
FAILURE: Build failed with an exception.
* What went wrong:
Unable to start the daemon process.
This problem might be caused by incorrect configuration of the daemon.
For example, an unrecognized jvm option is used.
Please refer to the user guide chapter on the daemon at http://gradle.org/docs/2.0/userguide/gradle_daemon.html
Please read below process output to find out more:
-----------------------
12:45:27.106 [main] DEBUG o.g.l.daemon.bootstrap.DaemonMain - Assuming the daemon was started with following jvm opts: [-Xms625m, -Xmx2048m, -Dfile.encoding=windows-1250] FAILURE: Build failed with an exception.
* What went wrong:
Could not create service of type DefaultClassLoaderRegistry using GlobalScopeServices.createClassLoaderRegistry().
* Try:
Run with --stacktrace option to get the stack trace.
Run with --info or --debug option to get more log output. Picked up _JAVA_OPTIONS: -Xmx4096M
* Try:
Run with --stacktrace option to get the stack trace.
Run with --info or --debug option to get more log output.
Picked up _JAVA_OPTIONS: -Xmx4096M
C:\Pylo\MCreator172\forge>
Task completed with return code 0 in 1254 milliseconds
I tried to reinstall Java and Mcreator after so I have latest version and Mcreator 1.7.2.

So... does anybody know solution for it

Last seen on 18:17, 1. Jun 2019
Joined Dec 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
I have a issue with
Wed, 04/26/2017 - 19:59

I have a issue with recompiling too, except it says every single mod element is broken!It Fails at the compilejava part, And It Says The "M" In the mcreator item is invalid or something?

Last seen on 13:53, 9. Aug 2019
Joined Mar 2014
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Hmm... how many GB of ram
Sun, 04/30/2017 - 09:52

Hmm... how many GB of ram have you got?

Last seen on 12:16, 6. May 2017
Joined Apr 2017
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
RE:Hmm... how many GB of ram
Wed, 05/03/2017 - 09:37

@#2 I have 12 GB RAM

Last seen on 00:07, 6. Apr 2018
Joined Mar 2017
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
RE:RE:Hmm... how many GB of ram
Wed, 05/03/2017 - 18:40

@#2.1 Have you allocated more ram?

Last seen on 12:16, 6. May 2017
Joined Apr 2017
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
i've tried but with no succes
Wed, 05/03/2017 - 21:51

i've tried but with no succes. Maybe i did it badly. Can you describe how?