My Whole Mod Is Broken?Recompiling keeps failing for every element!

Started by CreeperMiner on Wed, 04/26/2017 - 19:52

Topic category: Bugs and solutions

Last seen on 14:59, 28. Sep 2019
Joined Dec 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
My Whole Mod Is Broken?Recompiling keeps failing for every element!
Wed, 04/26/2017 - 19:52

It says theres a error with every single element!Its Never Done This Before Just Until Now!​Example: Its compiling but it says the "M" In the mcreator items or something should be something different!I dont want to start over my whole mod!Any Help... Please?

 

 

Last seen on 14:59, 28. Sep 2019
Joined Dec 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
This Is Serious And I hope it
Wed, 04/26/2017 - 19:56

This Is Serious And I hope it doesnt happen to anybody else!

And Yes!I tried recompiling three times and restarted the program 3 times!Nothing worked!Theres 100 errors!

 

Last seen on 14:59, 28. Sep 2019
Joined Dec 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
RE:This Is Serious And I hope it
Wed, 04/26/2017 - 20:04

@#1 example

mcreator_freakling mcreator_19 = new mcreator_freakling();
                                        ^
  symbol:   class mcreator_freakling
  location: class TestEnvironmentMod

Last seen on 22:52, 27. Oct 2017
Joined Nov 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Testing the 1.11.2 version
Wed, 04/26/2017 - 20:21

Testing the 1.11.2 version its buggy out really really bad, it does not work in so many places. I wonder if anyone as made a 1.11.2 proxy plugin to run 1.10.2 lol

Last seen on 13:18, 2. Dec 2020
Joined Jun 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Try to export your workspace,
Thu, 04/27/2017 - 05:53

Try to export your workspace, uninstall MCreator, install MCreator again and import your workspace.

Last seen on 13:18, 2. Dec 2020
Joined Jun 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
RE:Try to export your workspace,
Thu, 04/27/2017 - 05:53

I had this problem lots of times and the solution was this.

Last seen on 14:59, 28. Sep 2019
Joined Dec 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Exporting is broken and it
Thu, 04/27/2017 - 10:05

Exporting is broken and it says my mod contains errors which arent my fault! I Suppose im offically screwed over now because my mod cannot be saved!

Last seen on 14:59, 28. Sep 2019
Joined Dec 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
OH IM SORRY, I was using the
Thu, 04/27/2017 - 10:08

OH IM SORRY, I was using the wrong export.... oops.

Last seen on 08:40, 25. Mar 2018
Joined Apr 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Yes, you want to export the
Thu, 04/27/2017 - 11:45

Yes, you want to export the workspace, not the mod hehhe.

Last seen on 14:59, 28. Sep 2019
Joined Dec 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
.......How Do You Fix Your
Thu, 04/27/2017 - 19:25

.......How Do You Fix Your Workspace?

 

Last seen on 08:40, 25. Mar 2018
Joined Apr 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
For me, exporting it to an
Thu, 04/27/2017 - 19:59

For me, exporting it to an .mcr file, then re-importing it into one of the workspaces fixes it. Though, I get the problem again as soon as I change an existing block, or sometimes when I add a new one. :( So I have to keep repeating the process. This really needs to get fixed as it is counter-productive lol.

Last seen on 14:59, 28. Sep 2019
Joined Dec 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
My whole workspace is still
Thu, 04/27/2017 - 20:39

My whole workspace is still broken even though I got a brand new mcreator and stuff!Im really not happy because this is a mod breaking bug!

Last seen on 14:59, 28. Sep 2019
Joined Dec 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I mightve figured out the
Thu, 04/27/2017 - 20:53

I mightve figured out the actual issue

public class mcreator_VarList%MAINMODNAME% <- Gradle says theres a issue in this in regular build!

Last seen on 14:59, 28. Sep 2019
Joined Dec 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Nope wasnt it, sorry guys But
Thu, 04/27/2017 - 20:58

Nope wasnt it, sorry guys But Ill just give up using this application!