[Solved] MCreator won't set up

Started by Modier on Fri, 08/11/2017 - 17:42

Topic category: Help with MCreator's application

Last seen on 10:43, 14. Aug 2017
Joined Aug 2017
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
[Solved] MCreator won't set up
Mon, 08/14/2017 - 10:43 (edited)

Hello dear Community,

If I start MCreator for the first time it downloads the Forge MDK but if it setting up the Forge MDK I get an Gradle task error.

This is the log:

 

   
Executing gradle command: cleanCache clean setupDecompWorkspace --refresh-dependencies
Microsoft Windows [Version 10.0.15063]
(c) 2017 Microsoft Corporation. Alle Rechte vorbehalten.
C:\Pylo\MCreator175>cd forge
C:\Pylo\MCreator175\forge>SET "JAVA_HOME=C:\Pylo\MCreator175\jdk64\"
C:\Pylo\MCreator175\forge>SET JAVA_EXE=%JAVA_HOME%\bin\java.exe
C:\Pylo\MCreator175\forge>SET PATH=%JAVA_HOME%\bin\;%PATH%
C:\Pylo\MCreator175\forge>gradlew -Dorg.gradle.jvmargs="-Xms625m -Xmx2048m" cleanCache clean setupDecompWorkspace --refresh-dependencies 
FAILURE: Build failed with an exception.
* What went wrong:
A problem occurred configuring root project 'forge'.
> Could not resolve all dependencies for configuration ':classpath'.
> Could not resolve commons-logging:commons-logging:1.1.3.
     Required by:
:forge:unspecified
      > net.minecraftforge.gradle:ForgeGradle:2.2-SNAPSHOT
      > org.apache.httpcomponents:httpclient:4.3.3
> Could not resolve commons-logging:commons-logging:1.1.3.
> Could not parse Ivy file C:\Users\tfnaf\.gradle\caches\modules-2\metadata-2.16\descriptors\commons-logging\commons-logging\1.1.3\22da77b0d76ea8df17298218f3ec1f87\ivy.xml
> Content is not allowed in prolog.
> Could not resolve commons-codec:commons-codec:1.6.
     Required by:
:forge:unspecified
      > net.minecraftforge.gradle:ForgeGradle:2.2-SNAPSHOT
      > org.apache.httpcomponents:httpclient:4.3.3
> Could not resolve commons-codec:commons-codec:1.6.
> Could not parse Ivy file C:\Users\tfnaf\.gradle\caches\modules-2\metadata-2.16\descriptors\commons-codec\commons-codec\1.6\22da77b0d76ea8df17298218f3ec1f87\ivy.xml
> Content is not allowed in prolog.
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
BUILD FAILED
Total time: 2 mins 19.305 secs
C:\Pylo\MCreator175\forge>
Task completed with return code 0 in 150756 milliseconds

Using: MCreator for 1.11.2

Windows 10 64-Bit  2 or 4 GB RAM

but a year ago (I was uing the same device) it worked but now..

I hope you can help me. ;)

Edited by Modier on Mon, 08/14/2017 - 10:43
Last seen on 10:43, 14. Aug 2017
Joined Aug 2017
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
If you say that is because I
Fri, 08/11/2017 - 17:47

If you say that is because I don't have enough RAM an year ago MCreator worked and I had the same device

Last seen on 23:11, 12. Jul 2019
Joined Jun 2017
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
FAILURE: Build failed with an
Fri, 08/11/2017 - 17:48

FAILURE: Build failed with an exception.
* What went wrong:
A problem occurred configuring root project 'forge'.
> Could not resolve all dependencies for configuration ':classpath'.
> Could not resolve commons-logging:commons-logging:1.1.3.
     Required by:
:forge:unspecified
      > net.minecraftforge.gradle:ForgeGradle:2.2-SNAPSHOT
      > org.apache.httpcomponents:httpclient:4.3.3
> Could not resolve commons-logging:commons-logging:1.1.3.
> Could not parse Ivy file C:\Users\tfnaf\.gradle\caches\modules-2\metadata-2.16\descriptors\commons-logging\commons-logging\1.1.3\22da77b0d76ea8df17298218f3ec1f87\ivy.xml
> Content is not allowed in prolog.
> Could not resolve commons-codec:commons-codec:1.6.
     Required by:
:forge:unspecified
      > net.minecraftforge.gradle:ForgeGradle:2.2-SNAPSHOT
      > org.apache.httpcomponents:httpclient:4.3.3
> Could not resolve commons-codec:commons-codec:1.6.
> Could not parse Ivy file C:\Users\tfnaf\.gradle\caches\modules-2\metadata-2.16\descriptors\commons-codec\commons-codec\1.6\22da77b0d76ea8df17298218f3ec1f87\ivy.xml
> Content is not allowed in prolog.​

​Not sure how to fix that, try lowering the ram, install minecraft forge as itself if you haven't yet, or install a different version of Mcreator.

Last seen on 10:43, 14. Aug 2017
Joined Aug 2017
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
RE:FAILURE: Build failed with an
Mon, 08/14/2017 - 10:41

@#2 Ok Thanks I installed 1.7.2 for 1.7.10 and it worked. Thanks