Please help, would be appreciated (Mod not working)

Started by Dragma2005 on Mon, 09/04/2017 - 01:49

Topic category: Help with MCreator software

Last seen on 00:47, 20. Oct 2020
Joined Feb 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Please help, would be appreciated (Mod not working)
Mon, 09/04/2017 - 01:49 (edited)

Well, a while back I started making this mod with MCreator, but at a certain (unknown) point in development the test client enviornment stopped working, I can't test my mod. I have reported it as a bug multiple times and I haven't gotten a response, I even deleted some elements, re-installed MCreator with a backup of the mod, and more. Please help. Also, I WILL BE GETTING A NEW COMPUTER IN A FEW DAYS, SO IF THAT FIXES IT I WILL POST THAT ON THIS THREAD AND YOU DON'T HAVE TO SAY ANYTHING ELSE, OK? In case you want to know, this is the error log:

 

 

 

    Executing gradle command: clean runClient Microsoft Windows [Version 10.0.15063] (c) 2017 Microsoft Corporation. All rights reserved. C:\Pylo\MCreator175>cd forge C:\Pylo\MCreator175\forge>SET "JAVA_HOME=C:\Pylo\MCreator175\jdk64\" C:\Pylo\MCreator175\forge>SET JAVA_EXE=%JAVA_HOME%\bin\java.exe C:\Pylo\MCreator175\forge>SET PATH=%JAVA_HOME%\bin\;%PATH% C:\Pylo\MCreator175\forge>gradlew -Dorg.gradle.jvmargs="-Xms895m -Xmx2429m" clean runClient  This mapping 'snapshot_20161220' was designed for MC 1.11! Use at your own peril. #################################################          ForgeGradle 2.2-SNAPSHOT-d13a6c8           https://github.com/MinecraftForge/ForgeGradle   #################################################                Powered by MCP unknown                             http://modcoderpack.com                       by: Searge, ProfMobius, Fesh0r,                   R4wk, ZeuX, IngisKahn, bspkrs            ################################################# :clean :deobfCompileDummyTask :deobfProvidedDummyTask :sourceApiJava :compileApiJava UP-TO-DATE :processApiResources UP-TO-DATE :apiClasses UP-TO-DATE :sourceMainJava :compileJava :processResources :classes :jar :getVersionJson :extractNatives SKIPPED :extractUserdev UP-TO-DATE :getAssetIndex UP-TO-DATE :getAssets Current status: 304/1196   25% Current status: 977/1196   81% :makeStart :runClient 2017-09-03 20:48:49,791 WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream 2017-09-03 20:48:49,797 WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream [20:48:49] [main/INFO] [GradleStart]: Extra: [] [20:48:49] [main/INFO] [GradleStart]: Running with arguments: [--userProperties, {}, --assetsDir, C:/Users/T-Rex/.gradle/caches/minecraft/assets, --assetIndex, 1.11, --accessToken{REDACTED}, --version, 1.11.2, --tweakClass, net.minecraftforge.fml.common.launcher.FMLTweaker, --tweakClass, net.minecraftforge.gradle.tweakers.CoremodTweaker] [20:48:49] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker [20:48:49] [main/INFO] [LaunchWrapper]: Using primary tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker [20:48:49] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.gradle.tweakers.CoremodTweaker [20:48:49] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLTweaker [20:48:49] [main/INFO] [FML]: Forge Mod Loader version 13.20.1.2386 for Minecraft 1.11.2 loading [20:48:49] [main/INFO] [FML]: Java is Java HotSpot(TM) 64-Bit Server VM, version 1.8.0_101, running on Windows 10:amd64:10.0, installed at C:\Pylo\MCreator175\jdk64\jre [20:48:49] [main/INFO] [FML]: Managed to load a deobfuscated Minecraft name- we are in a deobfuscated environment. Skipping runtime deobfuscation [20:48:50] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.gradle.tweakers.CoremodTweaker [20:48:50] [main/INFO] [GradleStart]: Injecting location in coremod net.minecraftforge.fml.relauncher.FMLCorePlugin [20:48:50] [main/INFO] [GradleStart]: Injecting location in coremod net.minecraftforge.classloading.FMLForgePlugin [20:48:50] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker [20:48:50] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLDeobfTweaker [20:48:50] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.gradle.tweakers.AccessTransformerTweaker [20:48:50] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker [20:48:50] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker [20:48:50] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper 2017-09-03 20:48:50,300 WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream 2017-09-03 20:48:50,338 WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream 2017-09-03 20:48:50,340 WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream [20:48:50] [main/ERROR] [FML]: The binary patch set is missing. Either you are in a development environment, or things are not going to work! [20:48:50] [main/ERROR] [FML]: FML appears to be missing any signature data. This is not a good thing [20:48:50] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper [20:48:50] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLDeobfTweaker [20:48:52] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.gradle.tweakers.AccessTransformerTweaker [20:48:52] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.TerminalTweaker [20:48:52] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.TerminalTweaker [20:48:52] [main/INFO] [LaunchWrapper]: Launching wrapped minecraft {net.minecraft.client.main.Main} [20:48:53] [Client thread/INFO]: Setting user: Player231 [20:48:57] [Client thread/WARN]: Skipping bad option: lastServer: [20:48:57] [Client thread/INFO]: LWJGL Version: 2.9.4 [20:48:58] [Client thread/INFO] [FML]: -- System Details -- Details:    Minecraft Version: 1.11.2    Operating System: Windows 10 (amd64) version 10.0    Java Version: 1.8.0_101, Oracle Corporation    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation    Memory: 328681704 bytes (313 MB) / 465043456 bytes (443 MB) up to 1415053312 bytes (1349 MB)    JVM Flags: 0 total;     IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0    FML:     Loaded coremods (and transformers):     GL info: ' Vendor: 'Intel' Version: '4.3.0 - Build 20.19.15.4549' Renderer: 'Intel(R) HD Graphics 4400' [20:48:58] [Client thread/INFO] [FML]: MinecraftForge v13.20.1.2386 Initialized [20:48:58] [Client thread/INFO] [FML]: Replaced 232 ore recipes [20:48:59] [Client thread/INFO] [FML]: Found 0 mods from the command line. Injecting into mod discoverer [20:48:59] [Client thread/INFO] [FML]: Searching C:\Pylo\MCreator175\forge\run\mods for mods [20:49:00] [Client thread/INFO] [testenvironmentmod]: Mod testenvironmentmod is missing the required element 'name'. Substituting testenvironmentmod [20:49:01] [Client thread/INFO] [FML]: Forge Mod Loader has identified 5 mods to load [20:49:01] [Thread-6/INFO] [FML]: Using sync timing. 200 frames of Display.update took 499492094 nanos [20:49:01] [Client thread/INFO] [FML]: Attempting connection with missing mods [minecraft, mcp, FML, forge, testenvironmentmod] at CLIENT [20:49:01] [Client thread/INFO] [FML]: Attempting connection with missing mods [minecraft, mcp, FML, forge, testenvironmentmod] at SERVER [20:49:04] [Client thread/INFO]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:testenvironmentmod [20:49:04] [Client thread/INFO] [FML]: Processing ObjectHolder annotations [20:49:04] [Client thread/INFO] [FML]: Found 445 ObjectHolder annotations [20:49:04] [Client thread/INFO] [FML]: Identifying ItemStackHolder annotations [20:49:04] [Client thread/INFO] [FML]: Found 0 ItemStackHolder annotations [20:49:04] [Client thread/INFO] [FML]: Applying holder lookups [20:49:04] [Client thread/INFO] [FML]: Holder lookups applied [20:49:04] [Client thread/INFO] [FML]: Applying holder lookups [20:49:04] [Client thread/INFO] [FML]: Holder lookups applied [20:49:04] [Client thread/INFO] [FML]: Applying holder lookups [20:49:04] [Client thread/INFO] [FML]: Holder lookups applied [20:49:04] [Client thread/INFO] [FML]: Configured a dormant chunk cache size of 0 [20:49:04] [Forge Version Check/INFO] [ForgeVersionCheck]: [forge] Starting version check at http://files.minecraftforge.net/maven/net/minecraftforge/forge/promotio… [20:49:04] [Client thread/INFO] [FML]: Applying holder lookups [20:49:04] [Client thread/INFO] [FML]: Holder lookups applied [20:49:04] [Client thread/INFO] [FML]: Injecting itemstacks [20:49:04] [Client thread/INFO] [FML]: Itemstack injection complete [20:49:04] [Forge Version Check/INFO] [ForgeVersionCheck]: [forge] Found status: UP_TO_DATE Target: null [20:49:07] [Sound Library Loader/INFO]: Starting up SoundSystem... [20:49:07] [Thread-8/INFO]: Initializing LWJGL OpenAL [20:49:07] [Thread-8/INFO]: (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org) [20:49:08] [Thread-8/INFO]: OpenAL initialized. [20:49:08] [Sound Library Loader/INFO]: Sound engine started [20:49:12] [Client thread/INFO] [FML]: Max texture size: 8192 [20:49:13] [Client thread/INFO]: Created: 16x16 textures-atlas [20:49:13] [Client thread/INFO] [FML]: OBJLoader: Domain testenvironmentmod has been added. [20:49:13] [Client thread/FATAL] [FML]: Fatal errors were detected during the transition from INITIALIZATION to POSTINITIALIZATION. Loading cannot continue [20:49:13] [Client thread/FATAL] [FML]:     States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored    UCHI   minecraft{1.11.2} [Minecraft] (minecraft.jar)     UCHI   mcp{9.19} [Minecraft Coder Pack] (minecraft.jar)     UCHI   FML{8.0.99.99} [Forge Mod Loader] (forgeSrc-1.11.2-13.20.1.2386.jar)     UCHI   forge{13.20.1.2386} [Minecraft Forge] (forgeSrc-1.11.2-13.20.1.2386.jar)     UCHE   testenvironmentmod{1.0} [testenvironmentmod] (modid-1.0.jar)  [20:49:13] [Client thread/FATAL] [FML]: The following problems were captured during this phase [20:49:13] [Client thread/ERROR] [FML]: Caught exception from testenvironmentmod (java.lang.ArrayIndexOutOfBoundsException: 3) [20:49:13] [Client thread/INFO] [STDOUT]: [net.minecraft.init.Bootstrap:printToSYSOUT:600 // Don't be sad. I'll do better next time, I promise! Time: 9/3/17 8:49 PM Description: There was a severe problem during mod loading that has caused the game to fail net.minecraftforge.fml.common.LoaderExceptionModCrash: Caught exception from testenvironmentmod (testenvironmentmod) Caused by: java.lang.ArrayIndexOutOfBoundsException: 3    at net.minecraft.item.crafting.CraftingManager.addRecipe(CraftingManager.java:234)    at net.minecraftforge.fml.common.registry.GameRegistry.addShapedRecipe(GameRegistry.java:282)    at net.minecraftforge.fml.common.registry.GameRegistry.addRecipe(GameRegistry.java:277)    at mod.mcreator.mcreator_deathArmor.load(mcreator_deathArmor.java:61)    at mod.mcreator.TestEnvironmentMod.load(TestEnvironmentMod.java:891)    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)    at java.lang.reflect.Method.invoke(Method.java:498)    at net.minecraftforge.fml.common.FMLModContainer.handleModStateEvent(FMLModContainer.java:649)    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)    at java.lang.reflect.Method.invoke(Method.java:498)    at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74)    at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47)    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322)    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304)    at com.google.common.eventbus.EventBus.post(EventBus.java:275)    at net.minecraftforge.fml.common.LoadController.sendEventToModContainer(LoadController.java:253)    at net.minecraftforge.fml.common.LoadController.propogateStateMessage(LoadController.java:231)    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)    at java.lang.reflect.Method.invoke(Method.java:498)    at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74)    at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47)    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322)    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304)    at com.google.common.eventbus.EventBus.post(EventBus.java:275)    at net.minecraftforge.fml.common.LoadController.distributeStateMessage(LoadController.java:148)    at net.minecraftforge.fml.common.Loader.initializeMods(Loader.java:828)    at net.minecraftforge.fml.client.FMLClientHandler.finishMinecraftLoading(FMLClientHandler.java:357)    at net.minecraft.client.Minecraft.init(Minecraft.java:562)    at net.minecraft.client.Minecraft.run(Minecraft.java:387)    at net.minecraft.client.main.Main.main(Main.java:118)    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) AL lib: (EE) alc_cleanup: 1 device not closed    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)    at java.lang.reflect.Method.invoke(Method.java:498)    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)    at java.lang.reflect.Method.invoke(Method.java:498)    at net.minecraftforge.gradle.GradleStartCommon.launch(GradleStartCommon.java:97)    at GradleStart.main(GradleStart.java:26) A detailed walkthrough of the error, its code path and all known details is as follows: --------------------------------------------------------------------------------------- -- System Details -- Details:    Minecraft Version: 1.11.2    Operating System: Windows 10 (amd64) version 10.0    Java Version: 1.8.0_101, Oracle Corporation    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation    Memory: 511711608 bytes (488 MB) / 671612928 bytes (640 MB) up to 1415053312 bytes (1349 MB)    JVM Flags: 0 total;     IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0    FML: MCP 9.38 Powered by Forge 13.20.1.2386 5 mods loaded, 5 mods active    States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored    UCHI   minecraft{1.11.2} [Minecraft] (minecraft.jar)     UCHI   mcp{9.19} [Minecraft Coder Pack] (minecraft.jar)     UCHI   FML{8.0.99.99} [Forge Mod Loader] (forgeSrc-1.11.2-13.20.1.2386.jar)     UCHI   forge{13.20.1.2386} [Minecraft Forge] (forgeSrc-1.11.2-13.20.1.2386.jar)     UCHE   testenvironmentmod{1.0} [testenvironmentmod] (modid-1.0.jar)     Loaded coremods (and transformers):     GL info: ' Vendor: 'Intel' Version: '4.3.0 - Build 20.19.15.4549' Renderer: 'Intel(R) HD Graphics 4400' [20:49:13] [Client thread/INFO] [STDOUT]: [net.minecraft.init.Bootstrap:printToSYSOUT:600 :runClient FAILED BUILD FAILED FAILURE: Build failed with an exception. * What went wrong: Total time: 41.448 secs Execution failed for task ':runClient'. > Process 'command 'C:\Pylo\MCreator175\jdk64\bin\java.exe'' finished with non-zero exit value -1 * Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. C:\Pylo\MCreator175\forge> Task completed with return code 0 in 41986 milliseconds

 

Edited by Dragma2005 on Mon, 09/04/2017 - 01:49
Last seen on 19:56, 11. Aug 2019
Joined Aug 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
You started a test enviroment
Tue, 09/05/2017 - 18:06

You started a test enviroment right? Try just simply exporting your mod and playing it with normal Minecraft instead of the buggy test enviroment.

Last seen on 00:47, 20. Oct 2020
Joined Feb 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I tried that once and it…
Tue, 10/31/2017 - 21:20

I tried that once and it didn't work, but maybe I did something wrong

Last seen on 00:47, 20. Oct 2020
Joined Feb 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Nope, that doesn't work, I…
Thu, 11/02/2017 - 00:19

Nope, that doesn't work, I've just fixed a bunch of problems and the same thing happens, and I don't think the "Death Armor" is causing it.

Last seen on 00:47, 20. Oct 2020
Joined Feb 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
FINALLY! I TRIED REMOVING…
Mon, 01/22/2018 - 00:22

FINALLY! I TRIED REMOVING DEATH ARMOR (though I did that before and it still failed?) AND IT FINALLY WORKED! Thank the Lord.