If biome is selected, structures don't spawn

Started by Sweddy on Sun, 10/08/2017 - 14:24

Topic category: Bugs and solutions

Last seen on 16:40, 4. Oct 2018
Joined Sep 2013
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
If biome is selected, structures don't spawn
Sun, 10/08/2017 - 14:24

This would have been fine if it wasn't for the fact that if you set a structure to spawn in all biomes it will spawn all over the ocean.

Last seen on 21:50, 16. May 2019
Joined Jun 2015
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
What you could do is limit
Sun, 10/08/2017 - 14:33

What you could do is limit the structure so it can only spawn on grass.

Last seen on 16:40, 4. Oct 2018
Joined Sep 2013
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
RE:What you could do is limit
Mon, 10/09/2017 - 15:59

@#1 How? You're going to have to elaborate.

Last seen on 21:50, 16. May 2019
Joined Jun 2015
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
When opening your structure
Mon, 10/09/2017 - 16:17

When opening your structure gen on mcreator. There is an option to restrict spawn per block. Tick it then choose the block you want to restrict it to. When doing this it wont spawn over the ocean.

Last seen on 16:40, 4. Oct 2018
Joined Sep 2013
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
RE:When opening your structure
Tue, 10/10/2017 - 15:50

@#2 ok well, I tested your suggestions just now, and also set the spawn rate to 100000 spawns per 1000000 chunks to see if it would work. But the structure didn't spawn anywhere still. I use a schematic file, and didn't select "Choose a biome" or whatever. What could cause THIS issue then?